If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Always generates popups requesting regional components even though I will never install them

RESOLVED DUPLICATE of bug 86525

Status

()

Core
Internationalization
--
minor
RESOLVED DUPLICATE of bug 86525
13 years ago
4 years ago

People

(Reporter: Javier Fernández-Sanguino, Assigned: smontagu)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910

Www.debian.org (well, the whole site, not just the main page) is one of the few
serversthat has (in its footer) both content in your local language (through
content negotiation) and content in other languages. This content is used so
that people with broken content negotiation can easily "see" that the pages are
translated into their language.

It also has the side effect that, in Mozilla, everytime someone opens up any
page at www.debian.org which has been translated to languages which use
different fonts, a popup will show up asking the user to install regional
components. Most notably, the main page launches three popups related to (see
attachment): Simplified Chinese, Traditional Chinese, and Japanese.

Even though this might be good the first time, these warnings show up
_every_time_ you close the navigator window and start a new navigator. They are
not showed within the same browse session but if you close the browser, the same
popups will appear once again.

Me (like many other people) might be midly interested in knowing that I cannot
see hiragana, but I would like to be able to say (and have Mozilla save into my
preferences): "I will never install these regional components, please don't ask
me again". Unfortunately, the pop-us only have an 'OK' button and there is no
way to tell the browser 'Don't ask me again'.

This is midly anoying (but not too much, that's why I label it minor), but even
some users have reported this to the Debian webpage builders, see, for example:
http://lists.debian.org/debian-www/2004/08/msg00204.html

Reproducible: Always
Steps to Reproduce:
1. Launch mozilla navigator
2. Go to www.debian.org
3. Close the three popups that appear related to Regional Content
4. Navigate to any other link in www.debian.org (no popups)
5. Close Mozilla
6. Launch Mozilla
7. Go to www.debian.org
8. Close the three popups that appear related to Regional Content
9. Navigate to any other link in www.debian.org (no popups)
(....)

Actual Results:  
See attached file (step 2)

Expected Results:  
It should have shown a popup warning about the issue but with a 'Don't warn me
again' button in the popup window (together with the 'Ok') to discard these
messages forever. That information should be stored in the user's preferences.
(Reporter)

Comment 1

13 years ago
Created attachment 168310 [details]
Sample of the behaviour described
(Reporter)

Updated

13 years ago
OS: Windows XP → All
Version: unspecified → 1.7 Branch
(Reporter)

Comment 2

13 years ago
Reviewing the thread related to another user request (at
http://lists.debian.org/debian-www/2004/10/msg00074.html) and accessing
www.gnu.org (which also uses content negotiation and shows up fonts in other
languages) I now remember that this might be triggered because (in www.debian.org)
lang tags are used.

At gnu.org:
<a href="/home.ja.html">&#x65e5;&#x672c;&#x8a9e;</a><!-- Japanese -->

At debian.org:
<a href="index.ja.html" title="japanese" hreflang="ja" lang="ja"
rel="alternate">&#26085;&#26412;&#35486;&nbsp;(Nihongo)</a>&nbsp;

Even though this might be fixed if the HTML did not include the 'lang' tags I
believe this behaviour (popups when encountering unsupported languages) should
be customisable.

Sorry for not adding this to the initial bug report.
Core intl issue...  Also Windows-only, since the popups in question are
Windows-only.
Assignee: prefs → smontagu
Status: UNCONFIRMED → NEW
Component: Preferences → Internationalization
Ever confirmed: true
OS: All → Windows NT
Product: Mozilla Application Suite → Core
QA Contact: amyy
Version: 1.7 Branch → Trunk

Comment 4

13 years ago
http://lxr.mozilla.org/seamonkey/source/widget/src/windows/nsWindow.cpp#3852

Either we should prompt only once per profile (not per session) or should make
prompting configurable. by default, I guess it'd better be off... hmm, I'm not
sure. if it's off by default, there's no point keeping this.   do we really need
this service these days?

Btw, it's very ironic that this was reported by a Debian user and discussed on a
Debian list.

Comment 5

13 years ago
Perhaps, we can add buttons 'Never ask again' and 'I'll do it later'
(Assignee)

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 86525 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.