typeahead find causes problems if the tab was closed while the findbar was open

RESOLVED FIXED in mozilla1.8final

Status

()

Toolkit
Find Toolbar
--
minor
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Dorando, Assigned: Dorando)

Tracking

({fixed1.8})

Trunk
mozilla1.8final
fixed1.8
Points:
---
Bug Flags:
blocking1.8b5 +
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8a6) Gecko/20041208 Firefox/1.0+

.


Reproducible: Always
Steps to Reproduce:
Clean profile with javascript.options.showInConsole == true

1. Open a page in a second tab
2. Click on the current tab to ensure that the tab/label has the focus
3. Start typeahead find ('/') and close the tab immediately
4a. Start typeahead find ('/')
4b. Start Find (Accel+F) and enter something

Actual Results:  
Find fails.

3
  Error: document.commandDispatcher.focusedElement.parentNode has no properties
  Source File: chrome://global/content/findBar.js
  Line: 282
4a
  No reaction
4b
  Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsITypeAheadFind.find]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/findBar.js
:: find :: line 470"  data: no]


Expected Results:  
No errors.


Also happens with "Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6)
Gecko/20041208 Firefox/1.0+"

This seems to be a toolkit bug, but I can't file it there.

Comment 1

13 years ago
I can confirm this bug with Firefox 1.0+

The Severity of the bug needs to be changed to "critical" since the bug results
in a browser crash.
(Assignee)

Comment 2

13 years ago
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8b2) Gecko/20050309 Firefox/1.0+

Only the error on step 3 remains.
Severity: normal → minor
Version: unspecified → Trunk
(Assignee)

Updated

13 years ago
Flags: blocking-aviary1.1?

Comment 3

12 years ago
see also bug 286885 / bug 273200

Comment 4

12 years ago
confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050408 Firefox/1.0+

It's important to not miss the step two from original report. Also note that
it's different from bug 273200 in that the focus is not in FT (and the JS error
is different).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

12 years ago
*** Bug 286885 has been marked as a duplicate of this bug. ***
*** Bug 291010 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
That bug was not a dupe.  I saw this bug and noticed that it was not similar enough.

This bug is about find failing to find text in the tab, bug 291010 was about
failing to close the tab.

Comment 8

12 years ago
Confirmed Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8)
Gecko/20050511 Firefox/1.0.4. This is more serious than 'minor', it completely
breaks the Find function in the browser!
Can't reproduce even the error here on Linux or Windows trunk... minusing.
Flags: blocking-aviary1.1? → blocking-aviary1.1-
(Assignee)

Comment 10

12 years ago
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8b4) Gecko/20050715 Firefox/1.0+

I still get the error on step 3, but I need to close the tab with a middleclick now.
Flags: blocking-aviary1.1- → blocking-aviary1.1?
still can't reproduce, current trunk on multiple Windows machines, using the
reporter's latest set of instructions.  Gavin can't do it either.
Flags: blocking-aviary1.1? → blocking-aviary1.1-
(Assignee)

Comment 12

12 years ago
Alternative steps: (clean with javascript.options.showInConsole)
1. Open any link in a tab
2. Start typeahead with / or '
3. Middleclick on the current tab (there should be a focus ring)

Results in:
Error: document.commandDispatcher.focusedElement.parentNode has no properties
Source File: chrome://global/content/findBar.js
Line: 336

Error: document.commandDispatcher.focusedElement.parentNode has no properties
Source File: chrome://global/content/findBar.js
Line: 336

Comment 13

12 years ago
I can confirm on Linux-latest-trunk using steps in comment 12.

Middle-click a link, go to new tab, press "/", middle-click tab, open console,
view errors:

Error: document.commandDispatcher.focusedElement.parentNode has no properties
Source File: chrome://global/content/findBar.js
Line: 336

Error: document.commandDispatcher.focusedElement.parentNode has no properties
Source File: chrome://global/content/findBar.js
Line: 336
(Assignee)

Comment 14

12 years ago
Created attachment 192978 [details] [diff] [review]
Checking if the focusedElement has a parentNode
Attachment #192978 - Flags: review?(mconnor)

Updated

12 years ago
Attachment #192978 - Flags: review?(mconnor) → review+
(Assignee)

Updated

12 years ago
Whiteboard: [checkin needed]
(Assignee)

Updated

12 years ago
Attachment #192978 - Flags: approval1.8b5?
Assignee: firefox → bugzilla-mozilla
Hardware: PC → All

Updated

12 years ago
Flags: blocking1.8b5+

Comment 15

12 years ago
Comment on attachment 192978 [details] [diff] [review]
Checking if the focusedElement has a parentNode

Per bug meeting - approved for 1.8b5 branch.
Attachment #192978 - Flags: approval1.8b5? → approval1.8b5+
Seems like this was somehow forgotten, checked this in trunk&branch.

Trunk:
mozilla/toolkit/components/typeaheadfind/content/findBar.js; new revision: 1.28;

1.8 Branch:
mozilla/toolkit/components/typeaheadfind/content/findBar.js; new revision: 1.21.2.7;
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox1.5
QA Contact: fast.find
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.