Datepicker doesn't change month name April -- July

VERIFIED FIXED

Status

Calendar
Sunbird Only
VERIFIED FIXED
14 years ago
10 years ago

People

(Reporter: trio, Assigned: Mostafa Hosseini)

Tracking

Sunbird 0.2
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

   I only know that this happens on my machine, please confirm.

   When i use the date picker to choose a Start or Due Date, the months will
change the data (and the chosen selection will be correct), but the month is
labeled "March" even when it is April, May, June, or July!

   Weird. Maybe my machine has a ghost? :)
   Please check this.

Reproducible: Always
Steps to Reproduce:
1. Choose "New Event" or "New Task"
1a. (optional - fill in "Title")
2. Choose "Start" or "Due Date" drop-down date picker.
2a. (Today's date is 2004 dec 09, in case this bug turns out to be date specific.)
3. Click the "Right Arrow" to advance to the next month.
4. On the 4th click (in my case, going from 2005 March to April), the days of
the month change, but the calendar remains labeled as "March"!
4a. For some reason, the monthly labels return by "August".

Actual Results:  
Nevertheless, the function returns the correct data for the chosen Start or Due
Date.

Expected Results:  
The months April through July should have been labeled at the top of the
minicalendar.

Comment 1

14 years ago
I am not able to reproduce this behavior with 2004111214-cal on Firefox 1.0.

What version of calendar are you using? (Help | about calendar)
What locale?
Are there any errors in the JavaScript Console?
Component: Base → Sunbird and Calendar-Extension Front End
(Reporter)

Comment 2

14 years ago
   Thank you. Thats good news for the product - bad news for me.

> What version of calendar are you using? (Help | about calendar)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041112 Mozilla
Sunbird/0.2b

> What locale?

   I probably should know what this means, but i don't in a Windows XP context.

> Are there any errors in the JavaScript Console?

   Wow! I never noticed that was there. Yes, there are 2 (after i cleared them
and reproduced the error):
1. Error: Components.classes['@mozilla.org/autocomplete/controller;1'] has no
properties
Source File: chrome://global/content/bindings/autocomplete.xml
Line: 52

2. Error: Components.classes['@mozilla.org/autocomplete/controller;1'] has no
properties
Source File: chrome://global/content/bindings/autocomplete.xml
Line: 52

But they appeared when just opening "New Event". That's long before my supposed
bug of labeling the month incorrectly.

So, is it something i'm doing wrong?

   Thanks for your help with this.

Comment 3

14 years ago
Confirmed.

Happens on Sunbird 20041112, and a (limping) install of calendar 20041117 onto
Mozilla1.8a5.  (Was not able to install into nightly 20041209, failed silently.)

Does happen as reported in minimized width menulist date picker, but does not
happen in the fixed width minimonth tab (above task list).  May have something
to do with the length of the month name, as these months have short names in
English.  Can get the name written by waving mouse pointer over it, though old
name is not completely erased.

Does not happen on Calendar 20041112 on FF1.0. (1.7.5).

This suggests it is caused by changes in the underlying 1.8 trunk code, which is
undergoing revision... may revisit this after it settles down (maybe when
Mozilla 1.8a6 or 1.8b comes out).


Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Pickdate doesn't change month name after March 2005 → Datepicker doesn't change month name April -- July
Version: unspecified → Sunbird 0.2b
Assignee: shaver → mostafah
QA Contact: vladimir → brantgurganus2001

Comment 4

14 years ago
Created attachment 169645 [details] [diff] [review]
a patch to temporarily fix the bug by forcing moz to redraw

may be we can use this temporary fix before the actual redraw bug got fixed? 

furthermore, i am unable to find the corresponding bug in bugzilla, does
anybody know if it has a bug entry?
*** Bug 277636 has been marked as a duplicate of this bug. ***
*** Bug 278496 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
bug 199779 has a possible but imperfect patch that also seems to fix this problem.

Comment 8

14 years ago
marking target 0.2.
Target Milestone: --- → Sunbird 0.2RC2

Comment 9

14 years ago
I am having the same problem as the original poster of this bug.  I am running
Sunbird 0.2RC2 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5)
Gecko/20050111 Mozilla Sunbird/0.2RC2) on Windows XP SP 2.

On mine it does not show the correct month label until it gets to September.

Also, I noticed if I mouseover the month lable it will change to the correct month.

How to Repoduce:

1) Create a new event on any date in the months of January, February, or March
of 2005.
2) Drop down the start or end date, and press the right arrow to change the
month displayed.
  a) The dates will change to the proper corresponding dates for the month. 
However, the months of April through August appear with the month label of
March.  If you mouseover the actual label it will change to the correct month.
  b) Variant: If you create a new event in the months of April, May, June, or
July, it will display that month (the month you created the event in) until it
gets to September at which point it will switch to the correct label.
  c) Furthermore:  It does not matter what year you scroll to, or what year you
start with.



Comment 10

14 years ago
*** Bug 280599 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
problem also encountered on my host with Sunbird 0.2.
The behavior is exactly the same as described in comment #9

Configuration: Sunbird 0.2, Windows 2000 Professional

Comment 12

14 years ago
This bug is always present in 0.2 Final with XP, w98se
Is there an explanation on how to install the patch with Sunbird.

Thanks
*** Bug 285149 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
Bug 278877 contains a different fix, similar idea (redraw).  The problem only
occurs in the datepicker popup, so that patch uses the onchange handler.  (In
bug 278877 reshowing the popup is needed after month list or year list pops down
to prevent freeze, and it uses the same idea to redraw when the month changes.)
fixed in bug 278877
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 286093 has been marked as a duplicate of this bug. ***
*** Bug 286226 has been marked as a duplicate of this bug. ***
*** Bug 287906 has been marked as a duplicate of this bug. ***

Comment 19

13 years ago
*** Bug 288315 has been marked as a duplicate of this bug. ***
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird

Updated

11 years ago
Status: RESOLVED → VERIFIED
Target Milestone: Sunbird 0.2RC2 → ---

Updated

11 years ago
Version: Sunbird 0.2b → Sunbird 0.2
You need to log in before you can comment on or make changes to this bug.