Soft hyphen does'n works

RESOLVED DUPLICATE of bug 9101

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 9101
13 years ago
13 years ago

People

(Reporter: Vadim L Burmakin, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.5) Gecko/20041108 Firefox/1.0

[1 bug]

HTML Specification 4.0:
[http://www.w3.org/TR/html4/struct/text.html#h-9.3.3]

9.3.3 Hyphenation

    In HTML, there are two types of hyphens: the plain hyphen and the soft
hyphen. The plain hyphen should be interpreted by a user agent as just another
character. The soft hyphen tells the user agent where a line break can occur.
    Those browsers that interpret soft hyphens must observe the following
semantics: If a line is broken at a soft hyphen, a hyphen character must be
displayed at the end of the first line. If a line is not broken at a soft
hyphen, the user agent must not display a hyphen character. For operations such
as searching and sorting, the soft hyphen should always be ignored.
    In HTML, the plain hyphen is represented by the "-" character (- or
-). The soft hyphen is represented by the character entity reference ­
(­ or ­)

    In Mozilla Firefox 1.0 soft hyphen doesn't work at all. By the way, opera
and ie correctly works. So, try to fix that in next release of your really great
web browser.
    
    p.s. i'm from Russia and speaking english not very well.. Sorry.
    
    Vadim L Burmakin aka <El Desperado>. desperado@ipex.ru

--
some facts:
Windows XP SP2 English

please mail me if you understand..

Reproducible: Always
Steps to Reproduce:
create html file:
<html><head><title></title></head><body>
<table><col width="70" /><tr><td>
trying&shy;to&shy;view&shy;this&shy;long&shy;word
</td></tr></table></body></html>

Actual Results:  
html output: "tryingtoviewthislongword"
and table width resized from 70px to something bigger.

Expected Results:  
html output: 
"tryingto-
viewthis-
longword"
table doesn't resized, string is sliced.
IE loads this example correctly.

This function is very usefull in HTML4.0 spec. So, fix this, please.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 9101 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.