absolutly positioned div not recognizing a parent div as a containing block if parent has display:table set

RESOLVED DUPLICATE of bug 63895

Status

()

RESOLVED DUPLICATE of bug 63895
14 years ago
14 years ago

People

(Reporter: blakmajik, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Opera/7.54 (Windows NT 5.1; U)  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I have a div (#main_area) which needs to be able to expand to the right with 
the content (a table).  In order to acheive this in non IE browsers I have 
added display:table to the CSS to allow it to do just that.  I also have 
some small tabs (#sidebar) which I position:absolute to the outside of 
#main_area.  This works fine in Opera/IE/Konqueror.

The Problem:
Gecko doesnt seem to consider the div with display:table to be a containing 
block for the #sidebar div.  It goes all the way to the #main_area parent 
(#body_holder) and positions from there.

Reproducible: Always
Steps to Reproduce:



Expected Results:  
used the #main_area div to position from

*** This bug has been marked as a duplicate of 63895 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.