default text color when only bgcolor in website is specified (not text color) is sometimes wrong

RESOLVED WONTFIX

Status

()

Firefox
Preferences
--
minor
RESOLVED WONTFIX
14 years ago
12 years ago

People

(Reporter: Dennis Nezic, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

I like black backgrounds. So, I set my default background color to black, and my
text color to a light grey. Unfortunately, many sites are poorly designed, and
will only specify a bgcolor (white usually), assuming that we all have whitebg,
with blacktxt as our default colors. However, when I visit such sites, although
the background is set to white, my text color is too light to be read comfortably.

The same issue would arise if a website specifies a black text, but excludes the
bgcolor ... in which case i would not see anything because my default bgcolor is
black.

Perhaps, in the event that either the text or bgcolor are missing, mozilla
should force black-on-white and grey-on-black? Or perhaps, in the Fonts & Colors
settings, multiple "themes" should be defined ... depending on the background
color -- although perhaps this is unecessary, since black and white are the
predominant bgcolors ... and those that are actually colored will most likely
already have text/bgcolor/link/vlink already defined.

Also, while we're on the topic, I think a shortcut to force your preferred
Colors might be useful. Currently I have to perform 6 clicks and go through 2
dialogues. =)

Reproducible: Always
Steps to Reproduce:
the shortcut idea is extension fodder, I don't think we have enough shortcuts to
spare for something that most users will never use/have a need for.

As for having some sort of guessing scheme in place so if the pref text colour
is light, and the page background is set to be light, that's just something
that's going to mess with pageload times, and its just one of many types of
poorly coded pages.  I can't see enough of a justification for slowing every
pageload down for a bad assumption that only hits people who've changed default
colors.

Best bet would be to find/write/beg someone for an extension that would toggle
the pref to force your own colors on, but this isn't going to affect most users,
and fixing this would be adding code for an edge case that is more of a tech
evangelism case than anything.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

14 years ago
Created attachment 168532 [details]
a firefox extension that sets text color to black, if a webpage only specifies bgcolor

I made this extension to solve the problem. It should be useful to anybody who
uses black backgrounds by default, when encountering webpages that only specify
bgcolor (typically white).

The extension is slightly more sophisticated, in that it also checks if <td>
tags have bgcolors specified, but the page does not - in which case black text
is used.

I personally don't see any need to make it any more sophisticated. Do you?

Otherwise, the extension adds only one checkbox to the Fonts & Colors Dialogue
in the General Preferences section, which can be used to toggle the feature. It
is on by default.
(Reporter)

Updated

14 years ago
Attachment #168532 - Attachment is obsolete: true
(Reporter)

Comment 3

14 years ago
Created attachment 168667 [details]
txtbgfixer-0.2 .. includes keymapping (Ctrl-Shift-T)

this new version includes they Ctrl-Shift-T keymapping to cycle between 4
states:

1) off
2) on
3) use user-defined text/bgcolor
4) force all user-defined colors
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.