Complete file name missing (even the extension) when downloading files with spaces in names

VERIFIED DUPLICATE of bug 221028

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 221028
14 years ago
10 years ago

People

(Reporter: Seetharama Rao Durbha, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When using outlook web access (at least that is where I identified this
problem), if I click on a file that is attached to an email, I get the download
manager dialog box, but it does not come up with the complete file name - and
even the extension is missing, so the download manager is not able to pick the
program to open this file with.

Reproducible: Always
Steps to Reproduce:
1. Create a file with spaces in the file name
2. Send an email to another outlook mail id and attach that file
3. Use outlook web access to view that email and try downloading the attached file

Actual Results:  
Download manager will only show part of the file name (the first word only appears)

Expected Results:  
The complete file name, along with the extension, should have been shown. Also,
if the file extension is a known one, then the corresponding program should have
been automatically picked for Open with option.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 221028 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.