Closed Bug 274022 Opened 16 years ago Closed 5 years ago

"Mark as deleted" deletion model: add option not to to mark mail as read when deleting

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 465116

People

(Reporter: ndeb, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

This bug has been observed in all versions of mozilla messenger after 1.6
(includes 1.7 and 1.7.1/2/3 and the 1.8alphas). Messenger wrongly marks unread
mails as "read" when these emails are marked for deletion.

The same bug has crept into the thunderbird 1.0 release. Mozilla 1.6 is free of
this bug.

Reproducible: Always
Steps to Reproduce:
1. Make sure that messenger is configured to mark a mail as deleted when the
mail is selected and then delete key pressed. Then start messenger.
2. Change the view to "unread" to display unread emails only.
3. Now, select all/several unread emails by pressing keys "ctrl-a" and then
press the delete key.
Actual Results:  
The selected mails get marked as deleted as expected. In addition, they also get
marked as "read" which is not the right behavior. 

If the emails are now unselected and the deletion marks removed/undone, they do
not regain their "unread" status even though they have not been read at all.

Expected Results:  
The selected emails should have maintained their "unread" status at all stages,
as they used to in mozilla 1.6.
Confirming with current 1.8a6 build: If I delete a unread message, the msg is
moved to trash and is marked read.

Bug 211439 wants that. 
Severity: major → minor
OS: Linux → All
this is by design - more people want this behaviour than don't want it. Perhaps
someone can add a pref to control this...
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → WONTFIX
Please see comment 5 in bug 211439 .
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
I've changed it to an enhancement request and added the helpwanted keyword.
Severity: minor → enhancement
Keywords: helpwanted
Summary: mail marked for deletion also gets wrongly marked as "read" → add option to to mark mail read when deleting mail, off by default.
Since thunderbird 1.0 has the same issue, will this enhancement be included in
thunderbird as well?
Severity: enhancement → minor
yes, we'll put it in both. There's a little bit of backend work for this which
is shared across the apps, and some front end work to allow you to set the option.
Assignee: sspitzer → bienvenu
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: bienvenu → nobody
QA Contact: message-display
Hardware: PC → All
Summary: add option to to mark mail read when deleting mail, off by default. → add option not to to mark mail as read when deleting
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago10 years ago
Resolution: --- → EXPIRED
Still an issue.
Status: RESOLVED → UNCONFIRMED
Keywords: helpwanted
Resolution: EXPIRED → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: add option not to to mark mail as read when deleting → "Mark as deleted" deletion model: add option not to to mark mail as read when deleting
See Also: → 545504
I think that Bug 465116 made exactly the same request and was fixed by implementing a preference mailnews.ui.deleteMarksRead in Seamonkey. This bug thus looks like a duplicate of Bug 465116.
Whiteboard: dupeme
Yes, this was fixed as bug 465116. The reason to mark this bug as a dupe of a later one is of course that the later bug has the fix.
Status: NEW → RESOLVED
Closed: 10 years ago5 years ago
Resolution: --- → DUPLICATE
See Also: 545504, 465116
Whiteboard: dupeme
Duplicate of bug: 465116
You need to log in before you can comment on or make changes to this bug.