page with frame can be scrolled in print preview

RESOLVED DUPLICATE of bug 250545

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 250545
14 years ago
13 years ago

People

(Reporter: Jean Lambert, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

While print previewing a page with frames from the MSDN online library, only a
single page may be printed and the frame can be scrolled down (in print preview
mode) using the wheel mouse.

Reproducible: Always
Steps to Reproduce:
1. Open sample URL
2. Goto menu FILE -> Print Preview
3. Place mouse over the webpage frame (to the right of the index)
4. Scroll down with mouse wheel

Actual Results:  
The print preview only renders a single page and the frame on that page can be
scrolled. This makes no sense since you cannot physically scroll a printed page.
Also, there seems to be visible page breaks inserted inside that scrollable frame.

Expected Results:  
Firefox should at least give you an option to print the content of a single
frame and not necessarily print the web page as is with all the frames.

Comment 1

14 years ago
The expected results of bring able to print seperate frames can be found on the
normal print menu.

Comment 2

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223
Firefox/1.0.1

I have the same problem with the page at the link below. The contents of the
frame can be scrolled in print preview.

http://www.w3schools.com/html/tryit.asp?filename=tryhtml_frame_jump

Print preview in Internet Explorer shows the top of the frame's content in it
and it can't be scrolled. That is probably the proper behavior.

Comment 3

14 years ago
could this be a dup of 250545? https://bugzilla.mozilla.org/show_bug.cgi?id=250545

There is even an video at 250545.

*** This bug has been marked as a duplicate of 250545 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.