Tasks > Tools > Java Console menu to be disabled

VERIFIED DUPLICATE of bug 159969

Status

defect
P3
normal
VERIFIED DUPLICATE of bug 159969
20 years ago
9 years ago

People

(Reporter: nbaca, Assigned: nezbo)

Tracking

({platform-parity, relnote})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-] relnote-user)

(Reporter)

Description

20 years ago
Build 2000-02-10-08M14: NT4, Linux 6.0, Mac 8.5.1

If I did not assign this bug correctly then please reassign to the correct 
person.

Overview: It appears that the problems with the Java Console are not fixed based 
on bug# 21971 and bug# 22644. With the 2/10 build I noticed the following:

- NT4: A Java Console window appears
- Linux: Nothing happens
- Mac: Nothing happens

Based on this I'd like to place a dot in front of the "Java Console" menu item 
and also gray it out. Marking Beta1 since menu items that are not working should 
be disabled.
(Reporter)

Updated

20 years ago
Keywords: beta1

Comment 1

20 years ago
This is valuable for beta from our friends outside.
Whiteboard: [PDT+]

Comment 2

20 years ago
Based on how things are going so far, I'd say we probably won't get to fixing
21971.  My advice: monitor the status of 21971 until the last possible minute
that it's safe to make this change you suggest; if 21971 isn't resolved, then
go ahead and disable the Java Console menu item.

nbaca: will you be making this change yourself?
Depends on: 21971
(Reporter)

Comment 3

19 years ago
I'm in Mail/News QA and unable to disable the menu item if 21971 is not fixed.
Paul: Do you know who would do this?

Comment 4

19 years ago
I'll check around and try to find out who can do the deed.

Comment 5

19 years ago
Java console continues to work in Windows if you have the JRE installed. 2000022108.

OJI is not currently available on Linux. May need to gray out the Java Console
menu item.

OJI is no longer working on the Mac but may for Beta. I would wait on this.





Comment 6

19 years ago
Must fix by 02/25 to make the beta1 train.
Whiteboard: [PDT+] → [PDT+] Must fix by 02/25

Updated

19 years ago
Whiteboard: [PDT+] Must fix by 02/25 → [PDT+]w/b minus on 02/25

Comment 7

19 years ago
Moving to PDT-.  Did not make the deadline for beta1.  Putting on the relnote 
keyword.
Keywords: relnote
Whiteboard: [PDT+]w/b minus on 02/25 → [PDT-]w/b minus on 02/25

Comment 8

19 years ago
Deferring for now since Java works on Windows and Macintosh.
Status: NEW → ASSIGNED
Target Milestone: M16

Comment 9

19 years ago
This doesn't work on the Mac in the latest beta build.  

Comment 10

19 years ago
free george... this should be closed actually since 21971 is the bug due to other 
platforms working at this point.. (moving platform to mac)


Assignee: drapeau → loki-sun
Status: ASSIGNED → NEW
OS: Windows NT → Mac System 8.6
Keywords: pp
Hardware: All → Macintosh
Nominating nsbeta2. Java Console on Mac broken-->nsbeta2. Java on b2 list; need 
Console across platforms for us to be feature complete and PP. Clearing 
"[PDT-]w/b minus on 02/25" to trigger re-evaluation by PDT team.
Keywords: nsbeta2
Whiteboard: [PDT-]w/b minus on 02/25

Comment 12

19 years ago
Putting on [nsbeta2-] radar.  
Whiteboard: [nsbeta2-]

Comment 13

19 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.

Comment 14

19 years ago
No target milestone: no resources to work on Macintosh bugs right now.
Target Milestone: M16 → ---

Comment 15

19 years ago
Re-assigning this bug to myself, as Loki no longer works at Sun.  Leaving target
milestone as undefined, as there are no resources to work on Macintosh problems.
Assignee: loki-sun → drapeau
Whiteboard: [nsbeta2-] → [nsbeta2-] relnote-user

Comment 16

19 years ago
Re-assigning to Terry Noyes.
Assignee: drapeau → tnoyes

Comment 17

18 years ago
Updating QA Contact
QA Contact: paw → junruh
(Assignee)

Comment 18

18 years ago
please see bug #6872, as those proposed fixes appear to also cure the Java
Console bugs.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 19

18 years ago
The fix for bug #6872 landed yesterday, and I've tested successfully with a
yesterday build and a today build. Changing to FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 20

18 years ago
Reopening. Using the 4/10 commercial builds, I see:
- NT4: A Java Console window appears
- Linux: Java Console is greyed out
- Mac: Java Console is not greyed out and nothing happens.
This is inconsistent, since each platform behaves differently.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 21

18 years ago
What is the relationship of Mozilla (to which I have some access) to Netscape
(for whom I do not work) 6.x?  Are there separate trees and bug-tracking systems
such that the Mozilla bug #6872 changes might not show up yet in a Netscape
commercial build?

Comment 22

18 years ago
The main difference is in the XUL based chrome.  Another difference is that
several binary programs are bundled with Netscape that are not present in
mozilla, such as AOL Instant Messenger.  The native code is the same.  I think
it's safe to say that Netscape is mostly a superset of mozilla.
(Assignee)

Comment 23

18 years ago
I just pulled Mozilla anew and tried 27407, 6872, 21971, 31670, 69352, and 72585
with no problems.  Would suggest tester try a new pull of whichever browser he'd
like and enter a bug of 'Java Console menu item randomly grayed out' if the
tests then work okay.  Perhaps simply re-launching the browser can bring back
that menu item.

Comment 24

18 years ago
Fixed in the Netscape 6 Mac 2001041908 build. Tasks > Tools > Java Console opens 
the java console now.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 25

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 26

18 years ago
Tested 7-26-21-0.9.2 NS6.1, 8-07-15-0.9.3 Mozilla, 8-10-08 trunk NS Mac build. 
This still reproduciable. I reopen this.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Updated

18 years ago
QA Contact: junruh → shrir

Comment 27

18 years ago
I dunno if this is the right bug or 31670 is the correct one for the problem 
teruko sees. Basically, the console menu tem is grayed out.. Tnoyes, can you 
please check , thx !

Comment 28

18 years ago
SPAM: reassigning all OJI bugs to new OJI QA, pmac ( 227 bugs)
QA Contact: shrir → pmac

Updated

18 years ago
Blocks: 104166

Comment 29

17 years ago
isn't this issue fixed?

Comment 30

17 years ago
The underlying issue seems to have been fixed. Can we resolve this wontfix?
Java console is not opend on Mac 9.1 Build 2002072908
I am not sure, but i think that i have seen the Java Console one day
I begun with Mozilla with the 1.1a version. A regression ? or my memory fails ?

Comment 32

17 years ago
Jean, is this trunk build only right? Since this happens in the trunk build,
please refer to http://bugzilla.mozilla.org/show_bug.cgi?id=159969

Comment 33

17 years ago

*** This bug has been marked as a duplicate of 159969 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 34

17 years ago
verified dup of bugzilla bug: 159969
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.