Closed Bug 274108 Opened 15 years ago Closed 15 years ago

Fast find gets invoked unintentionally

Categories

(Toolkit :: Find Toolbar, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 258285

People

(Reporter: kevin, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When I click on a link in Thunderbird to open a url, sometimes the fastfind
incremental search feature gets invoked and has the keyboard focus.  I can't
seem to wrest the focus away from it.  When I restart Firefox, all is well.

Reproducible: Sometimes
Steps to Reproduce:
1.  Open a link which includes a cgi form with Thunderbird (not clear that this
step is necessary, but I'm 4 for 4 with it now.)
2.  Start to type in the cgi form.
3.  Witness that the characters go to the incremental search window, which of
course tries to find the characters in the page.

Actual Results:  
Step 3 states it.

Expected Results:  
The fast find (sub) window should NOT have been invoked and the incremental
search should not have been performed.
Oh, I see that I had the "begin finding when I begin typing" config item set in
the  accesibility config group.  If this is the cause of my bug, then please
close it.    However, I don't see the utility of this config item, at least when
combined with the fact that the user may wish to enter cgi form info. 
Firefox should not open the Find Toolbar if you have focused the textarea
manually. If it does, it is a bug. The same issue is reported in bug 258285, but
that bug is not reproducable, so if you can give us steps to reproduce the bug,
please do.
Well my comment regarding the accessibility does not seem to make any
difference.  I cannot repro it right now with the steps I posted, no matter if
that config option is on or not.
I shall try to capture my steps when it happens again.
all right, if you find a 100% steps to reproduce (or any ideas), please let us
know. Without additional info, the bug is essentially the same as 258285

*** This bug has been marked as a duplicate of 258285 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.