Opening a .PDF causes all current Firefox windows to go white until the .PDF finishes loading.

RESOLVED DUPLICATE of bug 274077

Status

()

Firefox
Shell Integration
--
minor
RESOLVED DUPLICATE of bug 274077
13 years ago
13 years ago

People

(Reporter: my386too, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When I click a hyperlink to open a .PDF file (using version 6.0.0.5/19/2003 of
Adobe Reader - I checked), any open Firefox browser windows have their workspace
turn white, and remain white until the windows that is downloading the .PDF file
finishes downloading and opens the .PDF file.  After this is complete, all
Firefox windows return to normal and display the correct content.  I made sure
that my antivirus and all three anti-spyware/adware programs are up to date and
scanned my system.  I shut down, and restarted without opening any other
programs.  At least on my system, it is consistently reproduceable.

Reproducible: Always
Steps to Reproduce:
1. Open Firefox
2. Go to a page with a link to open a .PDF file such the .PDF file at:
http://www.ee.ualberta.ca/~grover/EE390/Lab/Lab2.pdf
3. Click on the link/or enter the URL

Actual Results:  
All Firefox windows (the web page display windows) turned white and remained so
until the .PDF file was fully downloade.

Expected Results:  
Only the window involved in the download should have been affected.  Other
Firefox browser windows should have continued to be functional.

Aside from the described event, no other problems seem to occur after the .PDF
temporary "whiteout" of the browser windows.  The software remains stable and
fully operational.

Updated

13 years ago
Severity: normal → minor
wfm Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0

This is most likely due to increased processor power being taken due to loading
the pdf. While the pdf was downloading for me, firefox wouldn't respond, but
with my broadband connection, this period of no responce was only a few seconds,
which is normal even in IE when loading a PDF file.

Comment 2

13 years ago
Just wanted to report this bug also is very annoying under Linux (kernel 2.6.8,
KDE 3.3.1) with firefox 1.0, Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.5)
Gecko/20041207 Firefox/1.0 (Debian package 1.0-5)

When PDF files are opened and acroread (5.0.9) is associated with that filetype,
the CPU load goes to 100%, the computer is rendered useless until the loading of
the PDF has finished. It then continues to eat up about 90% of CPU to display
the file. Closing the tab/window with the PDF brings CPU usage down to 0.7% again.

Downloading the PDF and then opening it locally with acroread results in no
problems, as does using other browsers like Opera.

I can see very many similar bug reports, it might be worth accumulating them and
give them the "critical" status.

Cheers

J.

Comment 3

13 years ago
Help: I try to open pdf files and mozilla crashes. It was fine yesterday and I
have not made any changes to my computer. I installed the updated version of
mozilla, but problem persists...

Comment 4

13 years ago
this is verry annoying bug.
what the hell acrobat plugin wants from other firefox tabs?!?1?1?!?
even this depends of CPU or speed connection, why i have to wait stupid acrobat
to finish his job if i opened it in separate tab.

Comment 5

13 years ago
hm with acrobat reader 7 things are much better.

Comment 6

13 years ago
This appears to be not so much a load issue as an issue with exiting a PDF once
opened in Forefox.  Either hitting "back" on the browser, attempting to type
another URL in the address bar, or hitting a bookmark freezes my machine without
fail.  The only time this does not occur is when the PDF document is set up to
open in a new browser window.

Any thoughts?  This is a pretty annoying bug that does not occur in IE but I
still refuse to use IE (only for testing purposes).

Comment 7

13 years ago
I expereince the same issue on a daily basis. I click a link to download a PDF
and the window goes blank for several minutes - as I have left the page alone to
see if it is a loading issue or something else. If I go back to using IE, the
download prompt comes up asap & the pdf starts to download.

I need to download pdfs regularly and this is my only issue w/ firefox.

Comment 8

13 years ago
This bug is NOT a minor bug. It seems that the severity depends on the size and
speed of the download. For larger PDF files, the whole application freezes and
I've tried waiting up to 15 minutes, but the application got stuck. Killing the
Acrobat process will restore the application in a few minutes. 

I initially thought it was an Acrobat bug, however, under the same situation, IE
performs perfectly well, with no waits or freezes. Scolling to next page if the
PDF is not complete will just case a short waiting time, with everything
functioning in IE. However, in Firefox, when you try to scroll to next page, the
whole application will freeze.

Comment 9

13 years ago

*** This bug has been marked as a duplicate of 274077 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.