Editing the address on tabs in 1 fast click step instead of 3 click steps.

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: macster_smart, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Firefox 1 Final

I open links in new tabs then I must modify the address on the new opened tab 
because the link is of a redirected address so I click STOP the click on the 
address the entire address is selected then click again on the middle of the 
address where I wana modify the address, then I need to click again on the 
address then drag to the begining of the address to select that portion to 
delete it, then I can click on Go or press Enter to open the webpage.
The problem is that I need to click 3 times on that address to can edit it, 
when it can be done with one single click if Firefox it will be modifyed to 
work like this:
1. When I click on middle of the address to modify it, the address should be 
selected from the begining till the point I click on it (this time select the 
address from the begining to the middle) so the next thing I can do next is to 
press Delete to erase the unwanted redirect than I can open the webpage. And 
only if I click on the end of the address the entire address from the tab 
should be selected.


Reproducible: Always
Steps to Reproduce:
1. Middle click on one link in a webpage to open an address in a new tab.
2. Selecting the new tab then click STOP and begin to edit the address that 
shows like this http://cz11.clickzs.com/tgp.php?
spsh&http://galleries./19/9/n/index.html
3. First 1 click on the address selects the entire addres. Second 2 click 
deselect the entire address and point the editing cursor where you wana edit 
the address. The 3 click is needed to select the address from the point you 
have click on 2 click to the begining of the address, then you can press Delete 
to edit the address then press Enter to open it.
4. This address: "http://cz11.clickzs.com/tgp.php?
spsh&http://galleries./19/9/n/index.html" shows like 
this: "http://galleries./19/9/n/index.html" after the editing process.

Actual Results:  
It needs to many point and click actions to edit the address in the address bar.

Expected Results:  
The 3 clicks could easily be packed in 1 one single click, as I mentioned 
above. When I click on the address not the entire address should be select but 
only from the begining of the address to the point I click on the addres should 
be selected so I can press then on Delete to edit the address then open it (in 
this example from the begining to the middle of the address). The entire 
address should be selected only If I click to the end of the address.
The current behavior is by design, it isn't a bug. As an "enhancement" this
would no doubt be WONTFIXed, but as a bug it's just invalid. 

Had you taken your support request to the Mozillazine forums, you probably would
have been told how to use the Remove Redirects bookmarklet and how to set
browser.urlbar.clickSelectsAll to false, but as I've said several times, this
isn't the support forum.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
So youre conclusion is that Firefox does'nt need any more enhancements/improvments ?
That's the only conclusion i can draw from youre post.
If you wana make a better product from Firefox you guys should fix all related
bugs and add enhancements/improvments that will make it a better product than
what is now.

The atitude there at mozilla development seems to be like: "Don't bother to send
us your feedback, your feedback is worthless, we don't get your opinion in
acount, we have more brighter ideeas than yours, the most brighter ideea seems
to be like:WTF to improve this buggy product ?."

In this case I will stop reporting any bugs or enhancements because it is
worthless since you will not fix them.

BTW why Firefox cannot be simple to use like Internet Explorer ? 
Actually we need to install some extensions to have the same functionality like
IE I will enumerate 2 of them ShowImage and FlashGot, it is really that hard to
integrate them in Firefox build ? 
And lots ot things that don't work well in Firefox and we are forced to use
support Forums to know how to make some things to work. I have use IE for more
than 4 years and newer use a support forum to know how to use it, why Firefox
cannot be more simple to use like IE ?
One simple task is that we cannot install extensions in offline mode, some try
to explain on forum how to do it work but for my extensions it did not work ex:
ShowImage and FlashGot.
And you forget that there are few milion of users that use Firefox and don't
know very well english because they country language is other than english, they
cannot use a support forum as well as others, so the only thing you can do is to
make Firefox a better product so that users to not be forced to use support forums.
I hope you undertand what I wana say since my english is not my primary language
that I speak.
You need to log in before you can comment on or make changes to this bug.