If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Clicking on the button makes it shrink in size (float:left and next to select drop down)

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: dbaron)

Tracking

({helpwanted, testcase})

Trunk
x86
All
helpwanted, testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
Clicking on one of the buttons on that size makes them shrink.
I'll attach a minimal testcase.

It seems like a regression:
Not happening in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Happening in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718
(Reporter)

Comment 1

13 years ago
Created attachment 168568 [details]
Testcase
I don't see it shrink, but I do see a change in size.  Seems to regress between
2003-06-14-05 and 2003-06-15-05 nightly builds.

I don't really see anything in that range that would cause this, though.  :(

Comment 3

13 years ago
Created attachment 186711 [details]
Testcase #2

Comment 4

13 years ago
Tracing frame->GetStyleFont()->mFont.name and .size in nsHTMLReflowState::Init :
font=Arial,serif:240 in normal state and
font=Arial,serif:200 when the button is pressed (for Testcase #2, Line 1.)

Looks like a style system problem...
Assignee: nobody → dbaron
Component: Layout → Style System (CSS)
OS: Windows XP → All
QA Contact: layout → ian

Comment 5

13 years ago
Created attachment 186712 [details] [diff] [review]
fix?

This fixes it, I'm not sure exactly why 'medium' is needed there though...
Maybe this has something to do with it:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/style/nsRuleNode.cpp&rev=1.156&root=/cvsroot&mark=642-663#635

Comment 6

13 years ago
Bug 98765 seems the most likely culprit in the interval Boris mentioned...
(Assignee)

Comment 7

13 years ago
That looks like an invalid 'font' declaration.

Comment 8

13 years ago
Comment on attachment 186712 [details] [diff] [review]
fix?

Yeah, my mistake... so we should fix this then:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/style/forms.css&rev=
3.101&root=/cvsroot&mark=106#100
Attachment #186712 - Attachment is obsolete: true

Comment 9

13 years ago
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/style/forms.css&rev=3.101&root=/cvsroot&mark=106#100
(Assignee)

Comment 10

12 years ago
-moz-fixed is a generic font-family, -moz-button is a system font.
Perhaps what you want is:

font: -moz-button;
font-size: medium;

?
Keywords: helpwanted

Comment 12

12 years ago
see also bug 199755
Depends on: 199755
(Assignee)

Updated

11 years ago
QA Contact: ian → style-system
(Reporter)

Comment 13

10 years ago
This is now worksforme, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007120505 Minefield/3.0b2pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.