List of bugs that should be fixed as fast as possible.

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: macster_smart, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 

The next list of bugs should be fixed very fast in the next version of Firefox, 
because they are a list of bugs that will improve considerably the browsing 
process. 
I have to mention that the listed and actually unfixed bugs is creating me a 
lot of headaches, and if they are not fixed very fast in a new next version of 
Firefox, I will stop using this browser and I will never try it again and never 
consider it a reliable browser and not recomand it to another users.
Every bug from this list I have explained it in a more detailed report, and 
this is just a simple list that contains all bugs that I have find them till 
now and that I find them very anoyng and cause me a loot of problems when 
browsing:


Reproducible: Always
Steps to Reproduce:
1. STOP button on page don't work (after opening many tabs from an in progress 
opened webpage)
2. Save Page As delay problem (the Save Page As dialog needs more than 5 to 60 
seconds to show, so I can be able to save the webpage)
3. Save Page As on partially opened webpages problem (partialy opened webpages 
are downloaded completely if I wana save them partialy opened) 
4. Save webpage and Save Images As problem (the same directory path is used for 
saved webpages and images creating confusion)
5. Almost all Webpages are not displayed in Work Offline mode.
6. Many opened tabs issue, problem (more than 30 opened tabs opened cannot be 
selected)
5. Missing address webpage in new opened tabs (if I open an link in a new tab 
and the webpage failed to open I lose the link because it does not display the 
address before it start open the webpage)
6. Missing address webpage in new opened windows (if I open an link in a new 
window and the webpage failed to open I lose the link because it does not 
display the address before it start open the webpage)
7. Scroll too slow (one single scroll should scroll many lines in a webpage, 
exactly like the IE scroll where it scrolls faster)
8. Scroll problem on gif pictures (when over an animated gif picture I scroll 
the gif picture is scrolled some lines on top)
9.  On forum editing text problem. (after inserting BOLD, ITALIC, UNDERLINE, 
QUOTE ... etc. the pointer points to the begining of the editing text in page)
10. Firefox window automatically switch from Maximize to restore on some 
webpages.
11. Fast switch betwen multiple Firefox windows 
12. Disable warning mesages (disable the anoyng warning messages)
13. File>Close Window problem (If I have many opened webpages in many tabs and 
click on File>Close Window, it close the entire window without asking me if I 
wana close the Window because I have many tabs opened)
14. Close Tab delay problem (on some tabs one single middle click is not enough 
to close them)
15. Bad render of webpages (click on tooltips in webpages that have Flash 
animation and you will see some render anomalyes)
16. Offline instalation of extensions (We should be able to install extensions 
in offline mode, not only in online mode, so we can install versions of 
extensions that work fine with the installed Firefox version, because some new 
versions of some extensions does not work well with some Firefox versions)
17. History addresses small fix (typing of an already visited address then 
select it with arrows then left click with mouse on the Firefox window then 
click on Go does not open the webpage because the http:\\www. is missing from 
the address bar)
18. Bad render display of webpages with Firefox 1 Final. (on this address 
http://www.freeserials.com/ after making an search then click on the finded 
results you will notice one white square over the opened window, in Firefox 1 
PR this did not hapen)
19. Show Picture on rightclick should be included in Firefox not just an 
extension.
20. Firefox should use less CPU thread priority
21. Bad option File>Exit closes all Firefox opened windows instead of the 
curent window.
22. Browsing without typing www.
23. Selecting new opened tabs with addresses on them then press Enter did not 
open the webpage only if I select Go or select the address on the address bar 
then press Enter.
24. Editing the address on tabs in 1 fast click step instead of 3 click steps.
25. Some webpages are not saved in work offline mode

Actual Results:  
All this list of bugs should be fixed as fast as possible if you wana maintain 
or even increase your marketshare. If not I personally will stop using this 
bugy browser.

Expected Results:  
All this list of bugs should be fixed as fast as possible if you wana maintain 
or even increase your marketshare. If not I personally will stop using this 
bugy browser.

Comment 1

13 years ago
Please be serious.  One item per bug report.  And several of these things
already have bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Actually, all of those already have bugs reported. The reporter was saying "fix
all the bugs I reported, or I'll take my ball and go home."

Reporter: http://bugzilla.mozilla.org/page.cgi?id=etiquette.html has several
bits of useful advice on how to behave in Bugzilla in a way that will help get
things done, while not angering people enough to have them ask to have your
Bugzilla account cancelled. Not filing bugs like this, threatening to...
whatever if your bugs aren't fixed on your schedule, is item number two. Don't
do this.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

13 years ago
So you're sayng that everyone that sends feedback with bugs should be banned
(Reporter)

Comment 4

13 years ago
So you're sayng that everyone that sends feedback with bugs should be banned ????
You need to log in before you can comment on or make changes to this bug.