Preview message window shakes/resizes while checking for new pop mail

VERIFIED WORKSFORME

Status

Thunderbird
Mail Window Front End
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Jacob Maurer, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When I check for pop mail, the preview message window (I hesitate to call this
section of the front-end the 'preview pane' as in MS Outlook, but it Mozilla's
counterpart to this)  resizes, or perhaps scrolls down one or two pixels.  The
overall effect is that the message itself appears to shake.

This will only occur if the Thunderbird client is NOT maximized.

This only seems to occur on messages that have a large amount of text (5-20, or
more, lines of text below what is visible in the preview message window of the
main client

Reproducible: Always
Steps to Reproduce:
1.Open up Mozilla Thunderbird
2.Resize the window of the client so that it is not maximized - any size will do
3.Select a message that has a substantial amount of text that can not be shown
in the preview message window.

Actual Results:  
The displayed message appears to do a variation of the chicken dance - perhaps
the thunderbird dance (see above for a more accurate description)

Expected Results:  
The displayed message should simply be displayed, with no movement in the
preview message window.

This is Mozilla Thunderbird 1.0 running the following extensions:
Buttons! 0.4.9
Show SMTP Username 0.2.1
Minimize to Tray 0.0.1.20041203+
FoxyTunes 1.0
jsLib 0.1.238

The default theme is being used, although the following theme is installed:
LunaBlue for Thunderbird 0.3
(Reporter)

Comment 1

13 years ago
I just noticed, in moving a e-mails to a sub-folder, that the displayed message
in the preview message window did the exact same thing.

Also, when you put the cursor over a button and the little popup appears (the
alternate text describing what the button is), the shaking happens

In both cases, Thunderbird was NOT maximized (at least one constant).

I have a small (540 kb) avi of this, but was unable to attach it.  If you need
to see this in action (if you can't reproduce it yourself), feel free to e-mail
me at the provided address.
(Reporter)

Comment 2

13 years ago
Created attachment 168577 [details]
The Thunderdance (a 4-second video demonstration)

I managed to shrink down the size of the video.  This is an avi file encoded
with ffdshow MPEG-4 Video Decoder.

The problem occurs a bit faster than it does in the video, but you get the
general idea here.

Comment 3

13 years ago
(In reply to comment #0)
> the preview message window (I hesitate to call this section of the front-end
> the 'preview pane' ...

"Message pane."


> This is Mozilla Thunderbird 1.0 running the following extensions:
> Buttons! 0.4.9
> Show SMTP Username 0.2.1
> Minimize to Tray 0.0.1.20041203+
> FoxyTunes 1.0
> jsLib 0.1.238

Please run TB in safe mode (won't load the extensions) and report whether you 
still see the problem.  If not, try to narrow the behavior down to one 
extension, and then complain to the author.
(Reporter)

Comment 4

13 years ago
Mr. Cowperthwaite,

Dead-on advice.  An extension was indeed the culprit.  After uninstalling jsLib
(Mozilla Javascript Library version 0.1.238), the problem has gone away.  Thank you.

I'm resolving this bug as 'worksforme'

Respectfully,
Jacob Maurer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.