Closed Bug 274383 Opened 15 years ago Closed 15 years ago

Changing Text Size Causes Reading Place to be Lost (Severe on Text Rich Web sites)

Categories

(Firefox :: General, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 64926

People

(Reporter: nateperry333, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When changing the text size of any website, the text gets larger or smaller,
however the text you are looking at changes and the browser remains at the same
distance relative to the top of the page. 

I theorize that this can be solved by FireFox taking the relative place in the
HTML that is being displayed on the screen (Either the place at the top of the
page or, preferably, in the middle) and placing that spot at the top of the
screen after the resize (or in the center of the page, whatever).

Thank you.

Reproducible: Always

Steps to Reproduce:
1. Load any webpage with more than one screen full of text. Prefer multiple
screens of text.
Example: http://www.mozilla.org/releases/
2. Scroll halfway down the page.
3. Take note of what text you are looking at.
4. View>Text Size>Increase (Or Decrease)

Actual Results:  
If increasing the text size:
The text on the screen moves further down the page, forcing the reader to find
his place again.


Expected Results:  
Re-place the text being viewed on the screen or re-center on the text in the
middle of the screen

*** This bug has been marked as a duplicate of 64926 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.