Combobox onchange event fired late when using keyboard

VERIFIED DUPLICATE of bug 126379

Status

()

Core
DOM: Events
--
minor
VERIFIED DUPLICATE of bug 126379
13 years ago
13 years ago

People

(Reporter: Lubor Kolar, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
When using keyboard (up and down arrows or first letter) to change selected item
in the combo, "onchange" event is not fired instantly after each item change,
but only once - when item combo focus.
(Reporter)

Comment 1

13 years ago
Steps to reproduce:
1. Open http://www1.zivnobanka.cz/zbapp/kontakty/rezervacni_formular.do?lang=en
2. Select "Outlet" combo
3. Use arrows to change the item in the combo

Actual Results:
* opening hours (generated by the JS and launched by onchange combo event) are
not displayed (because no event was fired), you must unfocus this combo to get
opening hours displayed

Expected Results:
* onchange event should be fired after every change in combobox's selected item
even if combo is still focused (like MSIE does).
Severity: normal → minor

Updated

13 years ago
Assignee: general → events
Component: General → DOM: Events
Product: Mozilla Application Suite → Core
QA Contact: general → ian

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.