JavaScript toolbar breaks textarea edition history

RESOLVED DUPLICATE of bug 158071

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 158071
14 years ago
10 years ago

People

(Reporter: Jean-Michel Philippe, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
While editing a page in Wikipedia, clicking a toolbar button to format text
(e.g. the bold button) resets the textarea edition history instead of appending
the formatting operation.
The Wikipedia toolbar is based on the JavaScript method '<textarea>.value'.

NB: IE does not behave the same and actually updates textarea history when
invoking JavaScript, but the IE code is very different. Perhap's this is not a
bug indeed and there is a Mozilla JavaScript alternative that works fine?

NB2: try https://bugzilla.mozilla.org/attachment.cgi?id=67707 from bug
https://bugzilla.mozilla.org/show_bug.cgi?id=86372, this behave the same after
appending text with the button: history is reset.

Comment 1

14 years ago
So then this make its a duplicate of that bug?
No, unless I'm misunderstanding, this bug is "type 'foo', you can right click
and select 'Undo' and it goes away, but type 'foo', highlight it, and click the
button for Bold and then 'Undo' is disabled."

That is actually fixed in trunk nightlies (though for some reason you wind up
with 'Select All' afterward), but I can't seem to find where it was fixed, or
broken.
I think this was fixed by bug 158071.
(Reporter)

Comment 4

14 years ago
You're right this is the same bug. Sorry I didn't searched bug database for the
'input' keyword...
I saw the fix was in the 1.8a trunk and my Firefox 1.0 is based on 1.7.5, does
this mean the bug won't be solved until march 2005 with FF 1.1?
In terms of *releases*, yes, not until 1.1. If you really need it, though,
there's likely to be times when the nightly builds are more than stable enough
to use between now and then.

*** This bug has been marked as a duplicate of 158071 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.