If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Offers to forget a non-existent search

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Query/Bug List
RESOLVED FIXED
13 years ago
5 years ago

People

(Reporter: alanjstr, Assigned: gerv)

Tracking

2.19.1
Bugzilla 2.18
Bug Flags:
approval +
blocking2.20 +
approval2.18 +
blocking2.18 +

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
I deleted a saved search (by accident) and then used a bookmark that pointed to
it.  It returned " The search named UMO does not exist." and " Alternatively,
you can forget  this saved search: 'UMO'."

Dunno if this is a regression or just a general bug.
(Reporter)

Comment 1

13 years ago
Created attachment 168611 [details]
Output of non existant search
OS: Windows XP → All
Hardware: PC → All

Updated

13 years ago
Summary: Offers to Forget a Non-Existant Search → Offers to forget a non-existent search
(Assignee)

Comment 2

13 years ago
Created attachment 168898 [details] [diff] [review]
Patch v.1

This fixes the problem in the obvious way, and also tweaks the grammar. It's a
tip patch but applying it to 2.18 would be trivial.

Gerv
Assignee: justdave → gerv
Status: NEW → ASSIGNED
Attachment #168898 - Flags: review?(justdave)

Updated

13 years ago
Attachment #168898 - Flags: review+

Updated

13 years ago
Flags: blocking2.20?
Flags: blocking2.18?
Flags: approval?
Flags: approval2.18?
Attachment #168898 - Flags: review?(justdave) → review+
Flags: blocking2.20?
Flags: blocking2.20+
Flags: blocking2.18?
Flags: blocking2.18+
Flags: approval?
Flags: approval2.18?
Flags: approval2.18+
Flags: approval+
Target Milestone: --- → Bugzilla 2.18
(Assignee)

Comment 3

13 years ago
Fixed on trunk and branch.

Checking in template/en/default/global/user-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/user-error.html.tmpl,v
 <--  user-error.html.tmpl
new revision: 1.79; previous revision: 1.78
done

Checking in template/en/default/global/user-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/user-error.html.tmpl,v
 <--  user-error.html.tmpl
new revision: 1.61.2.8; previous revision: 1.61.2.7
done

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
*** Bug 300224 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.