Phantom text behind an inline img shouldn't have a visible border

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Doug Hockin, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
The phantom text that takes up the space for an inline <img> shouldn't ever
display a visible border.  The real text doesn't.

Updated

13 years ago
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Core
QA Contact: firefox.general → core.layout
Version: unspecified → Trunk
That's not "phantom text", but rather the <a> element, which you have styled to
have a border.  The layout is correct given that CSS.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
Thanks much.  I see now that you are correct.  But it does still seem a little
strange.  I just carefully moved the mouse pointer around those
double (red and green) borders and found that the active area for the <a>
includes both boxes, the union of the borders for the <a> and <img> are
included.  This wouldn't have been so noticable, except for the inadvertent
extra <space> included in the <a> element because I put the </a> on
a separate line, and the 'margin' I put on the last image.

I've put my modified version up instead of the original.

http://userweb.windwireless.net/~dough/Bug.html

I think "phantom text" is still a good name for the <a> border as it has
the same dimensions as text there would have had, with the exception of
the left/right border which are determined by the width of the <img>
box inside.  But the height of the <a> border is the same as the text
around it and the position of the the top and bottom borders is the
same as the text.  The width of the <a> border is the width of the
<img>, but it's height and placement follow that of the text.
You need to log in before you can comment on or make changes to this bug.