Closed Bug 27449 Opened 20 years ago Closed 20 years ago

After switching out of app and back in, can't select (focus horked)

Categories

(Core :: XUL, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: sfraser_bugs, Assigned: saari)

Details

(Whiteboard: [PDT+])

Chris: a reproducible way to kill selection in composer:
1. Run browser, and open composer. Type and select in composer (it works fine).
2. Switch to another application.
3. Switch back to Mozilla by clicking in any of its windows, or a title bar, or
   the application menu.
4. Note that you can no longer select in the frontmost composer window.
5. Note that switching to another mozilla window and back 'fixes' the focus so
   that you can now select.
This is beta for us.
Keywords: beta1
QA Contact: paulmac → sujay
Given that it makes composer unusable, please fix; marking PDT+.
Whiteboard: [PDT+]
Just tried with todays focus changes, looks fixed
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
this doesn't look fixed in 2/17 build. should I reopen this one?

I tried this on the Find dialog.
By the find dialog, do you mean Sherlock?
what does sherlock mean? I'm talking about Edit | Find in the composer window.

I lose the selection highlight when doing a Find and regain the selection
highlight after Cancel....
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Read the bug again, this one is about switching to another application on MacOS.

The Find dialog kills the selection because the subwindow gets a blur, as it does 
with all other top level windows. If you want that to not happen, the selection 
code can not listen to the blur, or special case it in some way.

Marking this bug fixed, again. There is, or was another bug on the Find dialog 
selection.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
verified in 1/17
You need to log in before you can comment on or make changes to this bug.