(Work-around): Shift+LeftClick for SaveLinkAs

RESOLVED DUPLICATE of bug 255181

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 255181
13 years ago
13 years ago

People

(Reporter: João, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Hi,

I've looked into getting Shift+LeftClick to do Save-Link-As, which seems to not
work in spite of the making ui.key.saveLink.shift = true in the prefs.js.

I've posted a work-around at the Mozillazine forum, please have a look at

  http://forums.mozillazine.org/viewtopic.php?t=183198&highlight=

Hopefully this will be implemented soon. :-)


Cheers
--J.

Comment 1

13 years ago
It's alt+click now. Not sure why the pref is still in about:config, you may want
to file a different bug on removing it.

*** This bug has been marked as a duplicate of 255181 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
Actually, I'm glad this pref was retained, as it allowed me to use this key
combination. Some window managers (namely, IceWM) capture the Alt+Click
combination before it can be passed to FF. Shift+Click seems to be the
workaround that suits me.

Are you REALLY planning to disable the ui.key.saveLink.shift in the next
release? :-(

Comment 3

13 years ago
er, the code that implemented this pref is already removed, isn't it? So it
would make sense to remove the pref too. (You'll be able to add it back in
about:config)
(Reporter)

Comment 4

13 years ago
Works for me.
(Reporter)

Updated

13 years ago
Blocks: 275342

Updated

13 years ago
No longer blocks: 275342
(Reporter)

Comment 5

13 years ago
Actually, I would like to change my vote. ;-)

It seems that more Window Managers than I thought support the Alt+LeftClick
combination for MoveWindow (Alt+RightClick for ResizeWindow). Of the WMs I've
tested, those that use are: KDE, Gnome, IceWM, (Open+Black+Flux)boxes, TWM,
Enlightenment. Those that I've found that do not use Alt+LeftClick: Afterstep,
WindowMaker, FVWM2.

So, it's more or less of a stalemate.

I suppose this is not an issue for MS Windows people, since Alt+LeftClick is not
used by that Window Manager (er... well, it is one!). It would be a shame to
remove the Shift+Click functionality from Firefox, since it gives an extra
option for people coming from other browsers (Galeon, Netscape 4.80, etc.),
where that option still exists.

You COULD bundle the FF package with the key set to false as default, but
removing the .jar code for using the Shift+Click instead would be (IMHO) a loss
for Firefox.

Comment 6

13 years ago
Ugh. The code isn't there. I think it was removed a long time ago, though I'm
not sure (you can check it in LXR). I think that if the Alt-click thing doesn't
work for majority of Linux users [I'm not sure if it is really so], there could
be a pref and/or a changed default for Linux. Anyways, please comment to the but
this one has been marked duplicate of and reopen that if you wish. If you do,
please comment to bug 275342 too. If I were you, I'd ask mconnor at
irc.mozilla.org, #firefox, he has the right to make decisions.
You need to log in before you can comment on or make changes to this bug.