Adding an or to boolean charts reduced the number of bugs found

VERIFIED DUPLICATE of bug 252889

Status

()

VERIFIED DUPLICATE of bug 252889
14 years ago
6 years ago

People

(Reporter: timeless, Assigned: justdave)

Tracking

Details

(URL)

For reference,

Query #1 is:
Bugs between -1m and Now where [Bug creation] changed
Group     is not equal to        0

Query #2:
Bugs between -1m and Now where [Bug creation] changed
Group     is not equal to        0    OR
Group     changed to             0

(figured out by copying the URL and replacing buglist with query in the url)

First thing I have to say is that "group change to 0" will *never* happen,
because group is a multi-select field, not a single value.  That said, it
shouldn't reduce the number of hits obtained by the first part.

Oh!  "changed to" creates a join on the activity table, which would cause fewer
hits if two of those bugs had never had any changes made to them because the
joins were done incorrectly.  This was fixed in CVS the day after we upgraded
bmo.  I'll add it to my list of post-upgrade patches to take.

*** This bug has been marked as a duplicate of 252889 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

14 years ago
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.