Maximizing window paints black over revealed page content area

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: Gtk
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Tuukka Tolvanen (sp3000), Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Seen on linux as follows:
                 gtk1  gtk2
firefox 1.0      ?     ok
seamonkey 1.8a4  ?     ok
seamonkey 1.8a5  ok    bug
firefox trunk    ?     bug

Frederic says he might have seen it on Windows, but it goes by too fast to tell
reliably.

Maximizing window paints black over revealed page content area, before reflowing
the page content. Presumably it is not the window base color, since that
accounts for the grey that appears before the black. Chrome area is not
temporarily painted black, only the page content area.

Occurs on e.g. about:buildconfig, https://bugzilla.mozilla.org/ front page, bug
lists, bug reports, but not on e.g. enter_bug.cgi. Some other sites, too.

Reproducible: always

STR:
 1. load https://bugzilla.mozilla.org/ or about:buildconfig
 2. unmaximize/restore window if necessary
 3. maximize window

Actual results: Revealed page content area painted black before page rendered again

Expected results: Render page without painting temporary black area.
(Reporter)

Comment 2

13 years ago
reading bug 288222 and bug 288117 just now gave me a hint... this display glitch
only happens when the maximizing causes a scrollbar (either or both) to go away.

updated STR:
 1. maximize window, decrease text size (ctrl -) if necessary so that there is no
    horizontal scrollbar
 2. unmaximize/restore window, resize so that there is a horizontal scrollbar
 3. maximize window
(Reporter)

Comment 3

13 years ago
Looks like this got fixed between 2005-03-27-16Z and 2005-03-31-16Z, and isn't
back at 2005-03-31-21Z (bug 288117 backout) so I'll blame bug 288222 for the
fix. Thanks :)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Depends on: 288222
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.