Firefox doesn't properly assign the remaining 100%

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: rohan, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Can you explain why Firefox doesn't properly assign the remaining 100% of a 
layer?

For example, put one layer alongside other items inside an outer layer with an 
assigned static width. Set the inner layer to take the remaining 100% of space 
left inside this outer layer.

Instead of doing this properly as Internet Explorer does, Firefox makes the 
inner DIV ignore the other items that are along side it, and simply sets it's 
width to the exact same as the assigned width of the outer layer. This results 
in stretching because there are other items inside the outer layer taking up 
space.

The URL:
http://www.rohanhill.com/test.html
Shows the specific error. Open it in Internet Explorer, and then open it in 
FireFox.
Can I? Yes. Is that an appropriate use of Bugzilla? No. Perfectly appropriate in
a CSS forum, or the Mozillazine Web Development forum at
http://forums.mozillazine.org/viewforum.php?f=25 but it's not a bug that you
haven't read http://www.w3.org/TR/REC-CSS2/visudet.html#the-width-property

Some free bug-related advice, though: you'll do best at detecting CSS bugs if,
when you see that IE does it one way and Gecko another, you start by assuming
IE's wrong, try to determine how they are wrong, and only reluctantly force
yourself to believe that Gecko's getting it wrong; and, as soon as the nightly
trunk builds get a little more stabilized, switch to using them: Gecko 1.7.5, in
Firefox 1.0, is lacking lots of correctness fixes that are in the current
builds. You can knock yourself out chasing down a little esoteric bug in 1.0,
only to be told that it was fixed several months ago, in a fix that didn't go
into the stable branch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

14 years ago
Well - you can be snooty about it, or you can realize that 90% of the world is 
using IE. I don't love Microsoft by any stretch of the imagination, but I guess 
I'm saying that it doesn't matter which browser is technically right or wrong. 
Designers design for IE - so if your browser doesn't render as well as IE, it 
is never going to gain a foothold.

Right?
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
This is a bug database, not a discussion forum. There are many other appropriate
places to discuss the philosophy of minority browser development. Do not reopen
bugs because you want the last word.

Percentage widths are calculated as a percentage of the containing block's
width. There's no ambiguity in that part of the CSS spec, and we aren't going to
misrender because IE got it wrong, or because IE implemented a previous version
of the spec before stopping development, or because IE implemented a WD before
stopping development.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

14 years ago
Hey, I just wanted to help you make your software work better. If you want to 
be a dick about it, that's your prerogative. I would suggest that in the 
future, you don't take offense at users pointing out flaws in what you've 
created. If you want to ignore problems with Firefox, you may as well close the 
bug reporting area all together. Either way, I'm not going to argue with you 
anymore. If you want a browser full of bugs, power to you :-)
You need to log in before you can comment on or make changes to this bug.