Firefox can't connect to internet if using VPN with a proxy

VERIFIED DUPLICATE of bug 274693

Status

()

Firefox
Migration
VERIFIED DUPLICATE of bug 274693
13 years ago
13 years ago

People

(Reporter: Martin Manscher, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

I dial-in to my workplace using a VPN connection. To access the internet when 
VPN connected, I use a proxy at my workplace. If not VPN connected, I don't 
use/need a proxy. In IE, the proxy is configured for the VPN connection, but 
not for the direct LAN connection. This way, I get internet connectivity 
whether or not I am connected to the VPN. In Firefox, there is only one proxy 
setting, so I have to change manually between "Direct connection to the 
Internet" and "Manual proxy configuration".

Reproducible: Always

Steps to Reproduce:
A1. Connect to VPN
A2. Try to connect to any web page

B1. Connect to VPN
B2. Change to manual proxy settings
B3. Connect to any site
Actual Results:  
A. Timeout

B. Connection to site

Expected Results:  
A. Connection to site.

B. Connection to site.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 274693 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.