Closed Bug 274709 Opened 17 years ago Closed 17 years ago

Incorrect rendering of input type="file" with CSS style set to width:100%,

Categories

(Firefox :: General, defect)

1.0 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 52500

People

(Reporter: cliff, Assigned: bugzilla)

Details

Attachments

(1 file)

See attached file for screenshot of how it is rendered.

The corresponding HTML Code:

<style>
.ntb{
color: black;
background-color: #c4d9ee;
border: 1px solid #bebcae;
font-family: tahoma;
font-weight: normal;
font-size: 8pt;
}</style>

...
<tr>
<td><strong>Attach File</strong></td>
<td><input type="file" name="file_to_attach" class="ntb" style="width:100%"></td>
</tr>
...


Expected Results:
Either the file stretches to the end like IE does, or the background-color
should not flow out of the text portion of the file upload input area.

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.