When loading new url which uses textbox focus(), steals focus from location bar when typing there during load

VERIFIED DUPLICATE of bug 125282

Status

()

Firefox
General
--
minor
VERIFIED DUPLICATE of bug 125282
13 years ago
11 years ago

People

(Reporter: Ian Macfarlane, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
When loading a web page that uses the focus() method onload, if you manually set
focus to the location bar and try and try something, once main page loads it
sets the focus to the textbox.

Therefore if you've loaded a URI and want to change it (or part of it which I
commonly do), part of what you've typed is present in the location bar, and the
rest of it appears in the textbox. The same is also true if focus is on the
search bar, find bar, or anything else.

I would suggest that if focus is manually set in something (location bar, search
bar, etc), that focus() doesn't take focus away from it (perhaps when pressing
tab to switch to the main window, we could automatically switch focus if it was
requested by the page, but that might be a separate enhancement request if this
is fixed). Most people will have focus on the window, or be opening a new
window/tab, so this won't be an issue for them.

Not quite sure which component to register this under, so feel free to assign
the correct one.

Updated

13 years ago
Blocks: 140346
This is a dupe, I've seen it, and dupes of it, a number of times.
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 125282 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Status: RESOLVED → VERIFIED

Updated

11 years ago
No longer blocks: 140346
You need to log in before you can comment on or make changes to this bug.