If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

misplaced text and combobox autoupdate does not work!

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Keyhan Hadjari, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.0 Branch
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
The rendering of the page is totallt incorrect.
Also when changing values of comboxboxes the page has to be refreshed and the
content of the comboboxes beneath them has to be updated which is not the case
when using firefox.

I got this error on Firefox 1.0 final edition.

Iguess the first bug should be a rendering issue and the second one a java
script issue.

regards.
No, actually the entire thing is an ASP issue: for some odd reason, Microsoft's
Active Server Pages product sees browsers in two groups: IE, and every other
browser on Earth, which are referred to as "downlevel browsers" and are given
completely different HTML and JavaScript, mostly aimed at working around bugs in
Netscape Navigator 4.x.

By ASP page standards, the rendering there isn't really half bad, and in fact
the dropdowns do work: you have to click the right-arrow image to the right of
them as you select options to get the refresh that you get automatically in IE,
but you can use the site.

However, the dropdowns are a nice illustration of how frustrating the "you're IE
or you're downlevel" split is: change your User-Agent string to identify
yourself as IE, so you get the completely different HTML, and the autochanging
works fine. (Other parts of the page actually crash us, but the select menu part
they could give to about anyone.)

If the site was completely unusable for us, I'd say to move the bug to Tech
Evangelism, but since it works, haltingly, and we certainly can't do anything
differently if they are giving us less-useful HTML which is mostly aimed at a
paleolithic browser, the only other resolution is the harsh INVALID.

What does work, though, is if you as a customer of SAS let them know that you
aren't happy about getting second-class HTML from their site, so that they as a
customer of Microsoft will let them know that they aren't happy about having a
tool which favors Microsoft's own browser over any others.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: JavaScript Console → General
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.