Problems when setting attributes in OnLoad Handler

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
19 years ago
18 years ago

People

(Reporter: scottputterman, Assigned: scottputterman)

Tracking

({verifyme})

Trunk
x86
Other
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
I'm just taking a guess by assigning to Nisheeth so please reassign if I'm wrong.

I just fixed 24182 where tree column headers weren't showing up in the mailnews
thread pane.  I found out that this was being cause by the fact that I was
setting an attribute on a column header during the OnLoad handler for the mail
window.  When I either comment out that line or put it in a setTimeout call, it
works.  This used to work without any problems before today's build.

Anyway, you can see this in mailnews/base/resources/msgMail3PaneWindow.js

Look for the line setTimeout("ShowThreads(false);", 0);

take the ShowThreads(false) out of the setTimeout call and the mail columns
should disappear.

I assigned to Nisheeth because I saw this happen today with other problems which
were similar to bugs I was seeing when asynchronous reflow was first turned on.
Anyway it's just a guess.

Comment 1

19 years ago
Scott, please check if this problem goes away if you set 
"layout.reflow.async.afterDocLoad" to false in your prefs.js file.  If so, 
please give this bug back to me.  If not, this bug is unrelated to async reflow 
and is caused by some other checkin.

Thanks.
Assignee: nisheeth → putterman
(Assignee)

Comment 2

19 years ago
may not be a problem anymore.  marking m20.
Status: NEW → ASSIGNED
Target Milestone: --- → M20
Per putterman's comment, marking verifyme.
Keywords: verifyme
(Assignee)

Comment 4

19 years ago
well, since none of the bugs I mentioned are still occurring, marking 
WORKSFORME.
(Assignee)

Comment 5

19 years ago
really marking WFM.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.