Closed Bug 274823 Opened 16 years ago Closed 11 years ago

Menubar, toolbar, status bar and find toolbar stop painting

Categories

(Toolkit :: Find Toolbar, defect)

1.7 Branch
x86
Linux
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: billy.biggs, Unassigned)

Details

Attachments

(1 file)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
GTK+ 2.4.13-1/pango 1.6.0-3 from Debian
Reproducable with both Debian's mozilla-firefox 1.0-5 package and the binaries
from mozilla.org.

1. Open a webpage
2. Hit Ctrl-F, find toolbar appears
3. Type in some characters, does not matter if they are found
4. Hit ESC, find toolbar disappears
5. Hit Ctrl-F, find toolbar reappears, old text appears selected but with no
   flashing caret
6. Hit backspace, nothing happens to the text
7. Mouse over the toolbars and status bars, these no longer paint and only
   show the widget background colour

I can reproduce this on my machine under kwin and also under X with no window
manager running.  When Firefox is in this state, it responds to key events, and
I can type in the URL bar (if I can guess where it is), but the find toolbar
seems unresponsive.  It's very odd.
Attached image Screenshot
I can confirm this behavior under Fedora Core 3. Been experiencing this problem
for a couple of weeks. I couldn't figure out exact steps to reproduce, but the
steps above do indeed reproduce the bug.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0
gtk2-2.4.14-1.fc3
pango-1.6.0-7
firefox-1.0-2.fc3
Is there any other information I can give you to help track down this bug? I'd
be happy to help in any way that I can.
Bug still exists in 1.0.1. As I said before, if there is any other information
you need to help track down the bug, I'd be happy to help.
This has been happening for me consistently in every 1.0.x version (and probably
before too).

Context menu also will not paint.

If I open a new window, it works fine.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 1.0 Branch
This just happened to me on a FC4 machine at work with GTK+ 2.6.7, metacity
2.10.0.  Previously I had never seen the problem running with the same version
of firefox.

The problem is so strange because it is consistently reproducable on my Debian
machine although I have upgraded pretty much everything since when I originally
filed this.  I had figured that maybe it was a combination of my X server
version and X driver (4.3.0/debian + mga), but at work I am using whatever X.org
version is in FC4 along with the Intel i845 driver.
Severity: normal → major
I just noticed that I'm not seeing this behavior anymore on FC3:

    gtk2-2.4.14-3.fc3
    pango-1.6.0-7
    firefox-1.0.4-1.3.1

Anyone still experiencing this, or can it be closed out?
I am still have this bug on :=
Gentoo
xorg-x11 6.8.2-r4
firefox 1.07
pango 1.8.1-r1
this has occured on all previous releases and is not dependant upon window 
manager or anything else that I can discover. I will post any further info if 
requested.


(In reply to comment #7)
> I just noticed that I'm not seeing this behavior anymore on FC3:
> 
>     gtk2-2.4.14-3.fc3
>     pango-1.6.0-7
>     firefox-1.0.4-1.3.1
> 
> Anyone still experiencing this, or can it be closed out?

I can still reproduce this the same as always on my Debian machine at home, now
running this version:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

It is reproducable on a clean X session with no window manager running.  I am
now using GTK+ 2.6.10, X.org 6.8.2.dfsg.1-8, and Pango 1.8.2.  I also disabled
acceleration for the mga driver and it still happens.  I can't think of what
else might be specific to my configuration.

I see these warnings now sometimes, however I don't think they were happening
earlier, and don't seem to be related to the problem (this happens once on
startup but sometimes I see a couple):

(firefox-bin:20201): Gdk-WARNING **: gdk_property_get(): length value has
wrapped in calculation (did you pass G_MAXLONG?)
Can't confirm this bug using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050902 Firefox/1.0.6. 

Gentoo 2005.1
xorg-x11 6.8.2-r2
nvidia-kernel 1.0.7676

While it happens every time at home, at work I've only seen it
when I hit Ctrl+F to bring up the find bar while Firefox is blocking
loading a complicated webpage.
Have you tried changing gnome themes?  What about Firefox themes? I have seen a number of problem like this, when themes had bizarre issues.   Sometimes widgets won't pain, other times borders are missing, etc, etc,.
The problem occurred with both clearlooks and Industrial, neither of
which are odd themes so I did not think it was theme related.  As well,
when in this state, input to the text entry in the find area was not
accepted (the caret did not move, although I think it did repaint).

I have so far been unable to reproduce this problem with firefox 1.5.
QA Contact: fast.find
Assignee: bross2 → nobody
Product: Firefox → Toolkit
WFM per comment 13
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.