bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Add new extension breaks after extension upload

RESOLVED FIXED in 1.0

Status

addons.mozilla.org Graveyard
Developer Pages
--
blocker
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Paul Grave, Assigned: wolf)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
Steps to reproduce:

1.  Log into developers section of UMO (I logged in as paul@ctomer.com).
2.  Click on "Add new extension"
3.  "Browse" to local file: translate-0.6.0.6-fx.xpi  (the file can be
downloaded here http://ctomer.com/extensions/translate/translate-0.6.0.6-fx.xpi)
4.  Click on "Next"

The following erros appear:
Warning:
move_uploaded_file(/opt/update-beta/files/temp/translate-0.6.0.6-fx.xpi): failed
to open stream: No such file or directory in
/opt/update-beta/developers/additem.php on line 55

Warning: move_uploaded_file(): Unable to move '/tmp/phpejONtW' to
'/opt/update-beta/files/temp/translate-0.6.0.6-fx.xpi' in
/opt/update-beta/developers/additem.php on line 55

I've also attached a screenshot.
(Reporter)

Comment 1

14 years ago
Created attachment 168850 [details]
Additem errors
(Reporter)

Updated

14 years ago
Attachment #168850 - Attachment description: Additem erros → Additem errors
(Assignee)

Comment 2

14 years ago
Confirming.

Looks like some part of the add chain still uses a hardcoded path. doh.
Severity: normal → blocker
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 1.0
(Assignee)

Comment 3

14 years ago
Created attachment 168851 [details] [diff] [review]
Fix hardcoded path to use $repositorypath variable

Fix hardcoded path to $websitepath/files to use $repositorypath variable.
(When testing, never use the old path as your $repositorypath variable. doh)
(Assignee)

Comment 4

14 years ago
Patch checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

14 years ago
Looks good, works as expected now.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.