Mozilla disregards browser.link.open_newwindow.* settings (no window.open() blocking)

RESOLVED WORKSFORME

Status

SeaMonkey
Preferences
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Max Alekseyev, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Mozilla linux build 2004121405

To reproduce:
1. Open about:config and set browser.block.target_new_window to 'true'
2. Restart Mozilla
3. Open provided URL
4. Click on "Форум по физике" link (left topmost one)
5. It opens in a new window

The bug occurs in the linux version of Mozilla. 

Mozilla Windows build 20040608 and OS/2 build 20041124 work as expected: the
link opens in the current window.

Comment 1

13 years ago
The parameter has changed by change of bug-org172962.
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=all.js&branch=&root=/cvsroot&subdir=mozilla/modules/libpref/src/init&command=DIFF_FRAMESET&rev1=3.552&rev2=3.553
(Reporter)

Comment 2

13 years ago
if so, what is the replacement for browser.block.target_new_window=true now?
And why Mozilla didn't convert old-style setting into a new-style one?
(Reporter)

Comment 3

13 years ago
browser.link.open_newwindow.restriction seems to be a replacement for
browser.block.target_new_window but according to
http://kb.mozillazine.org/index.phtml?title=About:config_Entries
it's Firefox only.
Nevertheless I tried all values of browser.link.open_newwindow.restriction in
Mozilla current linux trunk with no luck.
Depends on: 172962
Keywords: regression

Comment 4

13 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=172962#c213 & 218 explain this is
invalid

Seamonkey users do however need to know how to use its replacement until the UI
for it is enabled. I haven't found an existing bug for enabling the UI.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
No longer depends on: 172962
Resolution: --- → INVALID
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> https://bugzilla.mozilla.org/show_bug.cgi?id=172962#c213 & 218 explain this is
> invalid

Unless there is a working replacemen, it's a regression!

> Seamonkey users do however need to know how to use its replacement

Please please tell me how...
(Reporter)

Comment 6

13 years ago
I do not actually care what is the name for blocking option. The point is that
newly introduced option browser.link.open_newwindow.restriction does not work in
Mozilla (see comment 3), while good old browser.block.target_new_window option
was removed. I condiser this as a regression and a major lack of functionality.

So I change the summary and reopen the bug.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Mozilla/Linux disregards browser.block.target_new_window setting → Mozilla disregards browser.link.open_newwindow.* settings (no window.open() blocking)

Comment 7

13 years ago
The following is the contents which I checked the contents of a setting by
Firefox, and added to user.js.
Since I do not understand the meaning of a parameter, either, I think that the
same UI as Firefox is required also for Mozilla.


user_pref("browser.link.open_external", 3);
user_pref("browser.link.open_newwindow", 1);
user_pref("browser.link.open_newwindow.ui", 1);


Mac OS X 10.3.7
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20041216
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 8

13 years ago
(In reply to comment #7)
> The following is the contents which I checked the contents of a setting by
> Firefox, and added to user.js.

Thank you very much. The settings are counter-intuitive. So there is a definite
need for UI or at least some documentations.

Marking as WFM.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.