Closed Bug 274864 Opened 17 years ago Closed 17 years ago

Links in a table in a link give different results on left- and right-click

Categories

(Core :: DOM: HTML Parser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 266932

People

(Reporter: b_yurtcu, Unassigned)

Details

Attachments

(1 file)

Hello,

I couldn't understand the error. I can write the steps to regenerate the error:

1- Open new Firefox window.
2- For example go to this url: http://www.ntvmsnbc.com/news/300973.asp
3- This is a Turkish news portal, the site is Turkish. Scroll to bottom of the page.
4- Right click any link where under "GUNUN ONEMLI HABERLERI" header, and open it
in a new tab. That's ok. There are no error. But:
5- Don't open the link in a new tab, left click (open directly) the link. Here
is error! The site says: The link was not found.

Notice: I don't know, may be this error is the web master's error. May be the
web master didn't test the site for Firefox.

Regards,
Baris.
Attached file testcase
I suspect this must be a dup, though I can't find it. The problem is a section
of <a><table><tr><td><a></td></tr></a> which gives a rather odd DOM, and on
left-click gives us the href from the outer <a>, but on right-click gives us the
href from the inner <a>.
Assignee: bugs → tabbed-browser
Severity: critical → normal
Product: Firefox → Core
QA Contact: firefox.tabbed-browser
Summary: After clicking some links, Firefox sends wrong link string to other side. → Links in a table in a link give different results on left- and right-click
Curse you, Bugzilla, not that component.
Assignee: tabbed-browser → parser
Component: Tabbed Browser → HTML: Parser
QA Contact: mrbkap
Version: 1.0 Branch → Trunk
Indeed, this is a dupe.

*** This bug has been marked as a duplicate of 266932 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.