Add Extension: Fill Files Upload Form

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
14 years ago
2 years ago

People

(Reporter: mg_moz_dev, Assigned: alanjstr)

Tracking

unspecified
x86
Linux

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041006 Debian/1.7.3-4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041006 Debian/1.7.3-4

My email: mdev@scarlet.be
Extension download link:
http://home.scarlet.be/~mgius/fillfilesuploadform/fillfilesuploadform.xpi

Follows the readme that is included in the XPI:

The Fill Files Upload Form Extension to the Mozilla/Firefox Browsers
by Michele Gius 

Version 0.2
Localized for en-US, en-GB, de-DE, fr-FR

Tested on Mozilla 1.7.3 and FireFox 1.0 (only in en-US and fr-FR locale)
Installable on Mozilla 1.7 to 1.8a5 and FireFox 0.9 to 1.0

This extension was born to fill efficiently the upload forms of digital image
printing services. Mostly those services provide some ActiveX Control for
Upload with Internet Explorer (C) but no convenient solutions for other
browsers. Clicking 100 times on a browse button to fill each field on its own
is not my idea of fun ;-)

Usage:

This extension adds an entry "Fill Files Upload Form" to the Tools Menu.  When
called it opens a file picker dialog that supports multiple select. (Using the
<Ctrl> and <Shift> keys on your keyboard)

If you confirm the dialog by clicking on open, the extension looks for input
boxes of type file and fills them with the paths to the files you have chosen.
You are alerted if you choose more files than fit into the available form
fields, but the available fields are nevertheless filled.

If you do not select enough files to fill all available fields you can call the
extension again. It will start over filling the fields with the paths you
selected from the first free field onwards.

To reset all form fields to empty, just hold <Shift> and click on Reload to
force a reload.

Reproducible: Always

Comment 1

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Installs fine, does what it says it does, uninstalls cleanly.

Comment 2

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

Installs fine, and does as advertised, uninstalls fine.
(Reporter)

Comment 3

14 years ago
It was pointed out to me that the extension does not work on Yahoo's Briefcase
page. This was due to the fact that I did not take care of frames.

There is a new version of the extension (0.3.0), that does take care of frames
(works with Yahoo's Briefcase). In between I also added dutch localisation.

Details and the extension can be found at:
http://home.scarlet.be/~mgius/fillfilesuploadform/fillfilesuploadform.html
(Assignee)

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

13 years ago
Assignee: nobody → Bugzilla-alanjstrBugs
(Assignee)

Comment 4

13 years ago
Error! The MaxAppVer for Mozilla of 1.8a5 in install.rdf is invalid.

Try 1.8.  
Status: NEW → ASSIGNED
(Assignee)

Comment 5

13 years ago
WONTFIX:  No response in more than a week.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.