Add Extensions: A's Yahoo Mail Checker

RESOLVED INVALID

Status

RESOLVED INVALID
14 years ago
3 years ago

People

(Reporter: simonxyz, Assigned: Bugzilla-alanjstrBugs)

Tracking

unspecified
All
Windows XP

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

This firefox 1.0 extension checks for new mail in a yahoo! mail account.

Once you've installed it, right click on the envelope at the right of your
status bar. You'll see 3 options: Preferences (where you set your Yahoo!
username and password), Login and Logout. You need to login every time you open
your browser. Mail will be checked every 5 minutes, and a different envelope
will indicate that you have received new mail. In this version, only the inbox
is checked for new mail.

Reproducible: Always

Comment 1

14 years ago
"tested" on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6)
Gecko/20041215 Firefox/1.0+

Install correctly, shows up correctly, dont have yahoo so cant test any further,
but cliking login without entering details gives this error in the console:

Error: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED)
[nsIPrefBranch.getCharPref]
Source File: 
Line: 102

Maybe better to show a nice error dialog?
(Reporter)

Comment 2

14 years ago
Fix the javascript in version 0.5.2 , which is now the one available at the same url

Comment 3

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Installs and works fine, pretty much, except that I didn't notice the icon
change at any point when testing it. Uninstalls cleanly
(Reporter)

Comment 4

14 years ago
A line of code would fail in some browsers. Not sure why, but it has been fixed.
version 0.5.3 is now available for download

Comment 5

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Retested, Installs and Uninstalls fine, this time I see the icon change when it
finds new mail.  Thanks for this great extension.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: tested+
(Assignee)

Updated

14 years ago
Assignee: nobody → Bugzilla-alanjstrBugs
Whiteboard: tested+
(Assignee)

Comment 6

14 years ago
I had to remove the "A's" because UMO can't handle it.  I suggest you take a
look at the Gmail Notifier extension.  
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

14 years ago
New version 0.6 available at
http://www.latitudezero.org/extensions/yahoomailchecker.xpi

The old ext. won't work since yahoo changed their login process.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

14 years ago
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.