Tables in HTML mail display in wrong font

VERIFIED DUPLICATE of bug 28274

Status

MailNews Core
Backend
P3
normal
VERIFIED DUPLICATE of bug 28274
18 years ago
10 years ago

People

(Reporter: Richard Zach, Assigned: rhp (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Tables generated for the mail headers by forwarding plain text mail display in a
weird courier font as opposed to the standard serif font.

Linux build 2000.02.11.11

Attaching screenshots of mail displayed in message pane and composer.  The
source of the forwarded mail is:

<html><head></head>
<body> <br>
<br>
-------- Original Message --------
<table cellpadding="0" cellspacing="0" border="0">
<tbody><tr>

<th valign="Baseline" align nowrap>From: </th><td><a
href="mailto:bugzilla-daemon@mozilla.org">bugzilla-daemon@mozilla.org</a></td></tr><tr>

<th valign="Baseline" align nowrap>Subject: </th><td>[Bug 23878] Changed -
Mozilla hangs on file download after previous download was
cancelled</td></tr><tr>

<th valign="Baseline" align nowrap>To: </th><td><a
href="mailto:zach@math.berkeley.edu">zach@math.berkeley.edu</a></td></tr></tbody>
</table>

<br>
<br>
<pre>
<a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=23878">http://bugzilla.mozilla.org/show_bug.cgi?id=23878</a>

This bug depends on bug 26607, which changed state:
....
(Reporter)

Comment 1

18 years ago
Created attachment 5191 [details]
BAD: how it's displayed in the message pane
(Reporter)

Comment 2

18 years ago
Created attachment 5192 [details]
GOOD: how it looks in the composer when forwarding a plain text message

Comment 3

18 years ago
Reassign to rhp
Assignee: phil → rhp
(Assignee)

Comment 4

18 years ago
Will investigate post M14.

- rhp
Status: NEW → ASSIGNED
Target Milestone: M15
(Assignee)

Comment 5

18 years ago
Ok, this is actually a dup of a general font display issue. Here is the info 
that will help you get the display you want:

Here is the skinny: The message viewing display is currently controlled by the 
following preferences:

user_pref("font.name.monospace.x-unicode", "Font_Name");    --> plain text mail 
body
user_pref("font.name.serif.x-unicode", "Font_Name");   --> HTML mail body

user_pref("font.size.fixed.x-unicode", 12);   --> sizes in pixels
user_pref("font.size.variable.x-unicode", 16);  --> sizes in pixels

This is because all of our mail message display is Unicode (UTF-8).

- rhp

*** This bug has been marked as a duplicate of 28274 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

18 years ago
Note: you can easily edit your font choices for x-unicode in the prefs window.

- rhp
(Reporter)

Comment 7

18 years ago
Alright. Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.