Closed Bug 275046 Opened 17 years ago Closed 17 years ago

Input File incorrectly implements the "style=width:100%" attribute

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 52500

People

(Reporter: filipe.martins, Assigned: bugzilla)

Details

Hello.

I'm using FireFox 1.0 and I noticed this small glitch. Put the following code in
a page to see for yourself. The input file control won't take the whole area
assigned to it via "style=with:100%" attribute. Instead it will draw a white
line in the area it doesn't occupate.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Untitled Document</title>
</head>

<body bgcolor="gray">

<br><br>
<div style="margin:auto; width:80%">
	<input type="file" name="fl" style="width:100%">
</div>

</body>
</html>

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.