Closing thunderbird crashes it [@ nsMsgAccountManager::getServersToArray]

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: Vesa Jääskeläinen, Assigned: Scott MacGregor)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
User-Agent:       Opera/7.54u1 (Windows NT 5.1; U)  [en]
Build Identifier: version 1.0 (20041206)

TB2604970E

Reproducible: Sometimes

Steps to Reproduce:
1. Start TB.
2. Received some mail, read POP3, IMAP4 & NNTP groups.
3. After a while, try closing TB.

Actual Results:  
It crashes some times.


Expected Results:  
Thunderbird would close nicely.

Talkback crash ID: TB2604970E

I have another here, but can't remember was I closing it or not TB2571009W.
(Reporter)

Comment 1

14 years ago
Here is another bunch of talkback ID's: TB3147365Q, TB3060277Q, TB3056944W, 
TB3045649Q.

It might be somehow related with posting to NEWS servers. But directly testing 
by writing message to server doesn't seem to crash at exit. I have feeling 
that everytime it has crashed at exit I have at least written one NEWS message.

Comment 2

14 years ago
Stack Signature	0x03e96c16 6241e344
Product ID	Thunderbird10
Build ID	2004120606
Trigger Time	2005-01-18 16:05:44.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	
URL visited	
User Comments	I was closing thunderbird.
Since Last Crash	102262 sec
Total Uptime	1119208 sec
Trigger Reason	Privileged instruction
Source File, Line No.	N/A
Stack Trace 	
0x03e96c16
nsMsgAccountManager::getServersToArray 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/base/src/nsMsgAccountManager.cpp,
line 1327]
hashEnumerate 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsHashtable.cpp,
line 115]
nsHashtable::Enumerate 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsHashtable.cpp,
line 303]
nsMsgAccountManager::GetAllServers 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/base/src/nsMsgAccountManager.cpp,
line 1314]
nsMsgAccountManagerDataSource::HasAssertionAccountRoot 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/base/src/nsMsgAccountManagerDS.cpp,
line 1167]
nsMsgAccountManagerDataSource::HasAssertion 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/base/src/nsMsgAccountManagerDS.cpp,
line 1013]
CompositeDataSourceImpl::HasAssertion 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/rdf/base/src/nsCompositeDataSource.cpp,
line 1137]
CompositeDataSourceImpl::OnUnassert 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/rdf/base/src/nsCompositeDataSource.cpp,
line 1489]
nsMsgRDFDataSource::unassertEnumFunc 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/base/src/nsMsgRDFDataSource.cpp,
line 423]
nsMsgAccountManagerDataSource::OnServerUnloaded 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/base/src/nsMsgAccountManagerDS.cpp,
line 1298]
nsMsgAccountManager::NotifyServerUnloaded 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/base/src/nsMsgAccountManager.cpp,
line 1810]
nsMsgAccountManager::hashUnloadServer 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/base/src/nsMsgAccountManager.cpp,
line 953]
hashEnumerate 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsHashtable.cpp,
line 115]
nsHashtable::Enumerate 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsHashtable.cpp,
line 303]
nsMsgAccountManager::UnloadAccounts 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/base/src/nsMsgAccountManager.cpp,
line 1598]
nsMsgAccountManager::Observe 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/base/src/nsMsgAccountManager.cpp,
line 321]
nsObserverService::NotifyObservers 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsObserverService.cpp,
line 210]
nsXREDirProvider::DoShutdown 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/toolkit/xre/nsXREDirProvider.cpp,
line 501]
ScopedXPCOMStartup::~ScopedXPCOMStartup 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 783]
main 
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mail/app/nsMailApp.cpp,
line 58]
kernel32.dll + 0x16d4f (0x7c816d4f)
Keywords: crash
Summary: Closing thunderbird crashes it. → Closing thunderbird crashes it [@ nsMsgAccountManager::getServersToArray]

Comment 3

13 years ago
if I have been using Thunderbird for a while (hard to define), it crashes on
quit for me pretty regularly. I do not have any news accounts, I have two IMAP
accounts and a few blogs.

Track back IDs:
TB4702175K
TB4772996X

Windows XP home, Thunderbird 1.0.2 (and previous)

Comment 4

13 years ago
I get the "memory cannot be read" application error.  Would assume it was a
memory/mobo issue, but this is the ONLY program this happens with.  This only
started a week or so ago.  I was using version 08.  After this started, I
switched to 1.0.2, and it's still happening.  Found some mention of this
happening due to extensions being installed, so I removed the calendar.  No help
- it keeps crashing.

It happens EVERY time I use TB.  I only check an RSS feed and send/recieve POP3
mail.

Running WIN2K, fully patched.

I hope there's a fix for this, I dread the thought of going back to Outlook.

Comment 5

13 years ago
See Talkback ID TB7848405H or TB7891617Y.

I believe this happens when there is activity on an imaps account while the
thunderbird is closing.  I believe this happens if I exit Thunderbird when the
folders are being checked for new mail (I use procmail on the server to deliver
messages to different folders) or when I Compact Folders to remove messages
marked for deletion.

Thunderbird is 1.0.6, although I know this has happened since 0.7 for me with 2
imaps servers.  The first server is running dovecot version 0.99.11-1.0 on RH8
and the second is dovecot version 0.99.14-1.1 on FC4.

I had thought this was related to Bug #269571 of Bug #267575 but both are
closed.  One as a DUPLICATE and one as FIXED.
QA Contact: general
(Reporter)

Comment 6

11 years ago
Haven't seen this problem for a while so it is most likely fixed.

I am currently running: version 2.0.0.0 (20070326)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsMsgAccountManager::getServersToArray]
You need to log in before you can comment on or make changes to this bug.