Absolute path not allowed for servers.pab.filename pref.

RESOLVED DUPLICATE of bug 143451

Status

RESOLVED DUPLICATE of bug 143451
14 years ago
14 years ago

People

(Reporter: cdillon, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
In Thunderbird's prefs.js, "ldap_#.servers.pab.filename" cannot be set to an
absolute path, at least on Windows.

The following relative (to the profile dir) paths DO work:
user_pref("ldap_2.servers.pab.filename", "folder\\abook.mab");
user_pref("ldap_2.servers.pab.filename", "..\\abook.mab");

But these absolute paths DO NOT work:
user_pref("ldap_2.servers.pab.filename", "\\folder\\abook.mab"); 
user_pref("ldap_2.servers.pab.filename", "D:\\folder\\abook.mab"); 

It is possible to use an absolute path to relocate Firefox's bookmarks (pref
"browser.bookmarks.file").  The behaviour for the Thunderbird address book path
preference should mirror the behaviour of Firefox's bookmarks path preference.  
Ideally, all preferences referencing file names and locations should accept
absolute paths since users may wish to relocate other files as well.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 143451 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.