cookies not set under "preferred" method.

VERIFIED INVALID

Status

()

Core
Networking: Cookies
--
major
VERIFIED INVALID
14 years ago
14 years ago

People

(Reporter: shea, Assigned: Darin Fisher)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
while developing a website using PHP, i was needing to set a cookie.  my PHP
function that i normally use looks like this:

setcookie("cookie_name",$cookie_value,time()+31536000,"","." . $domain, 0);

...this normally sets a cookie whose domain is ".whatever.com".  (note that the
domain starts with a "." to indicate that this is a universal cookie).  while
this preceeding "." is NOT required, it is the "preferred" method as described
by microsoft for their IE.

while this preferred method is completely accepted by firefox for windows,
firefox for mac does NOT appear to allow cookies to be set using this
"preferred" method :(  

again, this problem only occurrs in firefox for mac osx.  (as i was able to
confirm it DOES work correctly for firefox for windows.)

please feel free to contact me should you have any additional questions.

rock on,

shea
shea@manhattanmulimedia.com

Updated

14 years ago
Assignee: bugs → darin
Component: Preferences → Networking: Cookies
Product: Firefox → Core
QA Contact: mconnor → core.networking.cookies
Version: 1.0 Branch → Trunk
Do you have a public testcase?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Do you have a public testcase?


dear de-bugger,

unfortunately i am unable to reproduce.  it would appear to be my mistake.

i am very sorry to have waisted your time.

respectfully,

shea
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 3

14 years ago
V/invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.