setvalue doesn't work inside a switch element

RESOLVED DUPLICATE of bug 277475

Status

Core Graveyard
XForms
RESOLVED DUPLICATE of bug 277475
13 years ago
2 years ago

People

(Reporter: aaronr, Assigned: smaug)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
This bug may be more wide reaching than I stated in the Summary, but that is how
I found the bug.  Basically inside nsXFormsSetValueElement::HandleAction it
calls nsXFormsUtils::GetModel() which will fail, due to a failure in
nsXFormsUtils::FindParentContext().  When it works its way up to the
nsXFormsSwitchElement::Process called by nsXFormsSwitchElement::GetContext, it
will fail in nsXFormsUtils::EvaluateNodeBinding.

Sorry I don't have more detail.  Trying to get out of here for the holidays.
(Reporter)

Comment 1

13 years ago
Created attachment 168990 [details]
testcase that shows problem
(Reporter)

Comment 2

13 years ago
reassigning bug to Smaug since he is most familiar with the switch element.  If
it turns out to be more in line with the context stuff that Allan works with,
please coordinate bug with him.  Thanks.
Assignee: aaronr → smaug
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

13 years ago
Aaron, did/does Bug 277475 actually fix this one too?
(Assignee)

Updated

13 years ago
Depends on: 277475
(Reporter)

Comment 4

13 years ago
Fixed with Darin's fix to 277475.  Sweet!

*** This bug has been marked as a duplicate of 277475 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.