Ability to e-mail bookmark URLs via menu item

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
14 years ago
10 years ago

People

(Reporter: blixman, Assigned: bugzilla-graveyard)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-UK; rv:1.7.5) Gecko/20041201 Camino/0.8.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-UK; rv:1.7.5) Gecko/20041201 Camino/0.8.2

I think the *send link* command should send the bookmark link when I'm viewing
the bookmarks. Ideally I could even send multiple links at once...

At the moment the *send link* command is a bit counter intuitive whilst viewing
bookmarks, it actually sends the link of the page hidden by the bookmark manager.

Reproducible: Always

Steps to Reproduce:
1. open bookmark manager
2. select any link
3. choose *send link*

Actual Results:  
the link of the page underneath the mookmark manager is sent

Expected Results:  
either the *send link* command to be greyed out (i.e. not available)

or sending the selected bookmark

Comment 1

14 years ago
Marking as a valid enhancement as we have a patch almost ready for the same
thing in the browser view. Would be a nice touch.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Future
Target Milestone: Future → Camino1.2

Comment 2

13 years ago
The "Email page location" command (previously known as "Send Link") now simply prepares an e-mail containing "about:bookmarks" if selected whilst viewing the bookmarks. We should implement the functionality documented in this enhancement or, at the very least, disable "Email page location" when displaying bookmarks/history.

Comment 3

12 years ago
The "E-mail page location" menu item is now greyed out when in the bookmark and history views. Given the name of this menu item I think that is correct.

Adding a "E-mail link(s)" option to the context menu when you have selected bookmarks/history items would however still make sense.

Updated

12 years ago
Assignee: mikepinkerton → nobody
QA Contact: bookmarks
In the interim, you can select all the bookmarks and Copy, or choose "Copy Locations to Clipboard", and then paste in your mail client.
(Assignee)

Comment 5

12 years ago
Tweaking summary.

What we ought to be doing here, per IRC, is changing the "E-mail page location" menu item to read "E-mail bookmark location" (or similar; we can decide on exact wording later) when bookmarks (or history items) are selected. This will require fixing the validation code too, which currently disables this item when about:bookmarks is active.

cl
Summary: Enhancement: Send Link in Bookmarks → Ability to e-mail bookmark URLs via menu item

Updated

12 years ago
Target Milestone: Camino1.6 → ---
(Assignee)

Comment 6

10 years ago
I need to fix this. Somehow this never made it onto my to-do list and the fix in comment 5 should be a pretty simple fix.

I don't think a contextual menu item is a good idea because it's just clutter, and I'm pretty sure that IRC discussion we had in 2006 came to the same conclusion. If any Camino devs disagree strongly with this, speak up now.
Assignee: nobody → cl-bugs-new
Hardware: Macintosh → All
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
(In reply to comment #6)
> I don't think a contextual menu item is a good idea because it's just clutter,
> and I'm pretty sure that IRC discussion we had in 2006 came to the same
> conclusion. If any Camino devs disagree strongly with this, speak up now.

Somewhere someone's rolling over in a grave, but I think that if we add this feature, having it in the Manager's Action menu is significantly more discoverable, and the Action menu = the context menu.

I'm not actually convinced that we need this feature, though. I've only once in my life wanted to email already-bookmarked sites, and that's when I was sending Marcia my huge list of Cocoa forms testcases; in that case, copy/paste worked just fine.

When this bug was filed originally, one of the acceptable expected results was "the *send link* command to be greyed out (i.e. not available)", which is the case today for "Email Page Location".

I don't think this feature is an 80% feature, it's currently just as easy to copy/paste, and I do like to hold the line against CM bloat, so I'm leaning towards WONTFIX on this one.
(Assignee)

Comment 8

10 years ago
WONTFIX per comment 7 and agreement of smorgan, hendy, and me on IRC.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.