Very long URLs (>=2048) are not accepted

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: denis.bach, Assigned: bugzilla)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

On some boards I post Edonkey/Emule links. With the new feature (Advanced
Hashsystem in URL Link) some of the links get very long. If the Link is longer
than 2048 Chars Firefox does nothing after clicking on the link. If the link is
shorter Firefox launched Edonkey/Emule. So it seams that the longer the URL is
the worser Firefox can handle it.
(Reporter)

Comment 1

14 years ago
Sourround the submited URL with the "<a href" tag and see yourself.
Might it be that this is (also?) partly a Windows problem? If i enter a normal
http URL with >=2048 chars, it works. 

Comment 3

14 years ago
Very long URI's have been working in nightlies and official releases because
people have been able to use huge bookmarklets and data URI's.

Example: Type into the location bar 'data:text/html,<a
href="data:text/plain,<<paste url from bugreport>>">test</a>'
That loads (which is longer than the original URL) as well as the link inside
the page.

Perhaps there is an issue with sending a very long URI to other protocols
(specifically the ed2k protocol). If you're still noticing the issue, you can
file a new bug stating that problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.