Shrink-to-fit abs.pos. is too narrow when preferred width > available width

RESOLVED FIXED

Status

()

Core
Layout: R & A Pos
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: mats, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CSS2.1 chap 10.3.7][reflow-refactor], URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

14 years ago
Shrink-to-fit abs.pos. is too narrow when preferred width > available width.
That is, when the shrink-to-fit width == avaialable width, according to
CSS2.1 chap 10.3.7:
http://www.w3.org/TR/CSS21/visudet.html#abs-non-replaced-width

This is the remaining case from bug 201897.
See also the corresponding bug for floats, bug 268499.
(Reporter)

Updated

14 years ago
Whiteboard: [CSS2.1 chap 10.3.7]
(Reporter)

Updated

14 years ago
Blocks: 145111
Whiteboard: [CSS2.1 chap 10.3.7] → [CSS2.1 chap 10.3.7][reflow-refactor]

Comment 1

14 years ago
Created attachment 175868 [details]
Testcase

I'm attaching an example that looks like this bug.  But as I understand it this
bug is not new, while my example worked in FF1.0.  Maybe some other regression
related to bug 201897's fix then?  This is a :hover pop-up menu.  In 1.8b1 The
menu that pops up is constrained to be no wider than its parent, the menubutton
that you hover over.  Previously (FF1.0) it was as wide as it needed to be.
(Reporter)

Comment 2

12 years ago
Comment on attachment 175868 [details]
Testcase

This testcase is unrelated to this bug and it's rendered correctly.
The reason the "popup menu" is not wider is that the available
width is the width of the <li class="b"> which has the width of
the word "Edit".
Attachment #175868 - Attachment is obsolete: true
(Reporter)

Comment 3

12 years ago
Bug occurs in Firefox 2006120701 on Linux.
Bug does not occur in Firefox 2006120801 on Linux.

-> FIXED (by the reflow branch landing)
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Depends on: 300030
Resolution: --- → FIXED
(Reporter)

Comment 4

12 years ago
URL is the testcase.  I'm not sure if it's already included in the layout regression tests or not.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.