Status bar doesn't change its content when finishing compacting folders

RESOLVED FIXED

Status

Thunderbird
General
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: toszcze, Assigned: Bienvenu)

Tracking

({fixed1.8.1})

unspecified
x86
Windows XP
fixed1.8.1
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
When I compact folders, status bar (at the bottom of a main window) shows 
message 'Compacting folder Inbox'. When this process is finished, description 
remains the same (but I think it should be cleared).
(Reporter)

Updated

13 years ago
Summary: Status bar don't change ist content when finishing compacting folders → Status bar doesn't change its content when finishing compacting folders

Comment 1

13 years ago
Possibly related to bug #216276?  I'm seeing both behaviors.

Comment 2

13 years ago
In mailnews/base/src/nsMsgFolderCompactor.cpp, ShowDoneStatus() gets called
inside CompactNextFolder() only. Thus, completion message works for compacting
all folders(file -> compact folders), but not for compacting individual folders.
At a glance, FinishCompact() seems to be better place to call ShowDoneStatus()
to handle the both cases.

Comment 3

13 years ago
*** Bug 274980 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
(In reply to comment #2)
> completion message works for compacting all folders(file -> compact folders),
> but not for compacting individual folders.

That's not what I'm seeing.  In TB, the completion message is not showing at 
all.  This problem was fixed in the Suite -- see bug 181627.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

13 years ago
I confirm this bug in TB 1.0.2 on Win2K when compacting a single folder as well
as all folders in an account. And I'd like to get it fixed.

Comment 6

13 years ago
T'Bird 1.0, WinXP SP2.
I experience the same behaviour.
It doesn't matter whether I compact a single folder or all folders, the status
bar fails to update when the final folder is done. I would really prefer a
separate modal dialog with progress bar that would (a) reflect the real progress
of the compaction tasks and (b) prevent me from accidentally corrupting my mail
by working with messages/folders while compaction is in progress. 

Comment 7

13 years ago
Confirmed (TB 1.06/W32 official build).

When compacting a folder via context-menu (right click) the progress indicator
does work propely, but when compacting is finished, the Status Bar still reads
"Compacting folder XXX...."

Updated

13 years ago
Flags: blocking1.8b5?

Updated

13 years ago
Flags: blocking1.8b5? → blocking1.8b5-

Comment 8

13 years ago
*** Bug 296725 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
Thunderbird Bug 271095 was duped against Suite Bug 181627, so this bug should perhaps also be duped against Bug 181627?

Comment 10

12 years ago
(In reply to comment #9)
> Thunderbird Bug 271095 was duped against Suite Bug 181627, so this bug
> should perhaps also be duped against Bug 181627?

No -- per comment 4, this bug still exists in Thunderbird (and I just retested and can verify that it's still in TB 1.5).  At the time that 271095 was duped, 181627 hadn't been fixed yet.

Comment 11

12 years ago
(In reply to comment #10)
> No -- per comment 4, this bug still exists in Thunderbird (and I just retested
> and can verify that it's still in TB 1.5).  At the time that 271095 was duped,
> 181627 hadn't been fixed yet.

 Presumably the code was forked before Bug 181627 was fixed.

 Obviously you're not affected by Bug 324085 in 1.5 on a PC.

Comment 12

12 years ago
When I see a compacting folders progress bar (Bug 324085 is intermittent) I also see "Done compacting folders" when it has completed. This is in Thunderbird version 1.5 (20051201) on Mac OS X 10.3.9.
(Assignee)

Comment 13

12 years ago
Created attachment 233256 [details] [diff] [review]
proposed fix

display the same status message in the single folder compact case. I changed the status message so we could use it in both cases - an alternative was to do Done compaction folder(s) but I don't know how localizable that is.
Assignee: mscott → bienvenu
Status: NEW → ASSIGNED
Attachment #233256 - Flags: superreview?(mscott)

Comment 14

12 years ago
Comment on attachment 233256 [details] [diff] [review]
proposed fix

David, if you want localizers to make a similar change to the meaning of compactingDone, you'll have to change the name of the string property otherwise localizations will continue to use whatever they translated "Done compacting folders" to in earlier releases.
Attachment #233256 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 15

12 years ago
Created attachment 239671 [details] [diff] [review]
ok, I've changed the string name to compactDone

this is what I'll checkin.
Attachment #233256 - Attachment is obsolete: true
(Assignee)

Comment 16

12 years ago
fixed on trunk and branch
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Comment 17

10 years ago
Sometimes, it doesn't show anything but other times, it does. I don't think this one is quite finished yet. Maybe another bug for compacting covers this. Will check.
You need to log in before you can comment on or make changes to this bug.