Flash has 'lag', stops momentarily and then restarts on most flash games

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: Brian Sawicki, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Flash plugin just stops for about 1 second, then restarts.  Severly detrimental
in games.
(Reporter)

Updated

13 years ago
Component: Tabbed Browser → General

Comment 1

13 years ago
I have noticed this as well.  For me it seems to be limited to when there are
multiple flash objects on the page. For example, one flash advertisement and one
flash game.  Both will perform poorly with much lag.  I am using the lastest
version of Mac.

Comment 2

13 years ago
The problem also exists in Windows 98SE with Firefox 1.0.4 and Macromedia Flash
7.0.  An excellent web site to see the problem is http://www.markfiore.com.
Click on any of Mark Fiore's animations using Firefox 1.0.4 (or Mozilla 1.7.8
or Netscape 7 or 8) and then try the same animation in Internet Exploder
6.0.2800.1106CO or later.  The lag will be readily apparent.  Actually, the
movements of the mouths on the screen won't match the audio -- they match very
well on Internet Exploder.

Comment 3

13 years ago
I hate to duplicate bug notices so I will simply attach to this one.  I have
noticed in the list many problems pointing to the Linux OS.  While developing
rather straightforward linear animations in Flash MX 2004, my students have
created scene to scene animations with very little actionscripting and I have
since published them on my web site.  Curiously enough, the hosting server is
using Linux.  When testing these movies locally in any browser (Netscape,
Safari, Explorer, Firefox), they work great.  However, when playing them down
from the server over the web in both Netscape and Firefox, in some of these
movies, I experience this lag.  Apparently there is a problem with Linux reading
the frame rate in these mozilla browsers and interpreting it correctly.
http://www.spiderpost.com/BDCS/studentprojects/lionandzebra.html

Comment 4

13 years ago
(In reply to comment #0)
> Flash plugin just stops for about 1 second, then restarts.  Severly detrimental
> in games.

We have developed an application where a user interacts with controls while
viewing a flash movie compiled in version 7. The movie becomes very choppy when
interacting with a slider component. It works perfectly in IE.

I think this is quite a significant bug

Comment 5

12 years ago
I'll add in my support for this bug.

Firefox on Windows XP, it works fine.  Firefox in Linux, stuttering occurs.

Here's my example of where it occurs, and a potential clarification of the symptoms:
http://70.84.34.106/~mediaun/ngame.swf

In the game, you control a little stick figure.  If you hold down the right or
left arrow keys to run, the pause occurs just shortly after you begin running in
that direction, but there there isn't another pause until you change directions
(either by jumping with SHIFT or holding the other arrow key to run in a new
direction).

Comment 6

12 years ago
I noticed also this problem on the Citro├źn web site : http://www.citroen.fr
Assignee: bugs → nobody
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: tabbed.browser → plugins
Version: 1.0 Branch → Trunk

Comment 7

11 years ago
Do you still see this problem with current version of browser AND flash player?
Please comment in the bug with your version and status.

* http://www.adobe.com/products/flash/about/ shows your currently installed version.
* latest test version http://labs.adobe.com/downloads/flashplayer9.html
* current mass release for linux 9,0,48,0 http://www.adobe.com/products/flashplayer/

Comment 8

10 years ago
of the two URLs that still work, the work fine with flash 9.
so not FF bug
=> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.