Search result contains bookmarks which have already been deleted

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: torisugari, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
When I search bookmarks in the sidebar, a bookmark I deleted is listed 
as a search result.

Steps to reproduce:
1. Create a bookmark you have never bookmarked page (e.g. this bug page).
2. Delete it.
3. In bookmarks manager/sidebar, search the bookmark (enter bug#).

Actual Result:
The bookmark is in the list.
Expected Result:
Nothing comes up.

This is a kind of undo/redo transaction bug.

Comment 1

14 years ago
xref Seamonkey Bug 123679

Comment 2

14 years ago
confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050401 Firefox/1.0+
Status: UNCONFIRMED → NEW
Depends on: 123679
Ever confirmed: true
Version: 1.0 Branch → Trunk

Updated

14 years ago
Version: Trunk → 1.0 Branch

Updated

13 years ago
Version: 1.0 Branch → Trunk
Confirming w/ firefox 1.0.6 and Windows XP SP2

Actually this bug is much worse than first descibed as it really garbages up the
search results with multiple entries for the same bookmark wether it is deleted
or not.  In one of my tests a single deleted bookmark showed up 37 times in the
search results.  In another test it occured 14 times and a 3rd test only
produced it once.

Here is my test procedure to confirm this bug.  Test 1:
1. add a bookmark for this page by dragging to bookmark manager
2. search on '275249'
3. delete the bookmark
4. search on '275249'
Result:
37 instances of the same bookmark are displayed both before and after deleting it.
If you have the 'Locate in bookmark folders' extension installed you can easily
distingquish between these 'phantom' and 'real' bookmarks because the Locate
button will not become active when a phantom bookmark is highlighted.

Test 2:
1. same procedure as test 1 except:
2. add a bookmark for any other web page whose page name does not contain a number
Result:
Same as test 1 except that 14 rather than 37 instances occurred

Test3:
1. same procedure as test 1 except:
2. add the bookmark by manually creating it by right clicking 'new bookmark' and
manually typing the name 'unique bookmark'
Result:
Same as test 1 except only 1 instance of the bookmark occured.
Also different in this case, the 'delete' bookmark button is active after
already deleting it but clicking delete again does nothing.

Could the owner or power user of this bug please change the severity to major
since 37 'phantom' search results for any single bookmark wether deleted or not
deleted completely ruins the usefulness and credibility of the search feature.
test ignore
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Comment 6

12 years ago
Still present in 2.0:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0 - Build ID: 2006101023

Comment 7

10 years ago
should be WFM on current trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081215 Minefield/3.2a1pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Version: Trunk → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.