Closed Bug 27531 Opened 20 years ago Closed 19 years ago

Account Wizard's first textfield needs auto-focus.

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 24871
Future

People

(Reporter: hyatt, Assigned: sspitzer)

Details

Platform: Win98

(1) Bring up account creation.
(2) Hit Next to move to the pane where you can enter your name and email 
address.
(3) Type your name.

Expected Result: Focus should be moved into the first text field when you switch 
into this pane so that you can begin typing immediately.
Actual Result: Focus is not placed into the first text field.

If this is done using generalized wizard code, on a pane switch, you can get the 
first XUL control by saying document.controls[0], and you can then call focus() 
on this control.

The same problem plagues the profile wizard.  These wizards should share as much 
JS as they can.
Reassign to alecf, cc ben
Assignee: phil → alecf
fix in hand, works for all wizards
Status: NEW → ASSIGNED
Whiteboard: fix in hand
Target Milestone: M14
checked in.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
QA Contact: lchiang → nbaca
Build 2000-03-06-10M15: NT4
Build 2000-03-06-13M15: Linux 6.0
Build 2000-03-02-08M15: Mac 8.5.1
Reopening. In the Account Wizard's Server dialog, I have to click onto the 
"Server Name" text box to see the cursor. 

The cursor appears in the first text box for all other Account Wizard dialogs.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
augh. I guess what I did was give focus to the first form field, when I really
should have given it to the first textbox.
Status: REOPENED → ASSIGNED
Target Milestone: M14 → M17
Minor UI fixups to M18.  If this is incorrect, please adjust.
Target Milestone: M17 → M18
moving to future milestone.
Target Milestone: M18 → Future
reassign to sspitzer
Assignee: alecf → sspitzer
Status: ASSIGNED → NEW
Whiteboard: fix in hand
URL: C
Summary: Can't type immediately in Mail Account Creation wizard → Account Wizard's first textfield needs auto-focus.
URL: C

*** This bug has been marked as a duplicate of 24871 ***
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.